package/libupnp18: add optional dependency to openssl/libressl
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 2 Apr 2018 08:21:51 +0000 (10:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 4 Apr 2018 19:40:47 +0000 (21:40 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libupnp18/libupnp18.mk

index a75558e92b73203cdee7a6556481a3fa9350840a..07ef4382f01f1b727df29c43be3fe446337fe7f8 100644 (file)
@@ -12,4 +12,12 @@ LIBUPNP18_INSTALL_STAGING = YES
 LIBUPNP18_LICENSE = BSD-3-Clause
 LIBUPNP18_LICENSE_FILES = LICENSE
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBUPNP18_CONF_OPTS += --enable-open-ssl
+LIBUPNP18_DEPENDENCIES += host-pkgconf openssl
+LIBUPNP18_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libssl libcrypto`"
+else
+LIBUPNP18_CONF_OPTS += --disable-open-ssl
+endif
+
 $(eval $(autotools-package))