erlang: use erlang's native atomic ops
authorFrank Hunleth <fhunleth@troodon-software.com>
Thu, 10 Mar 2016 00:22:05 +0000 (19:22 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Jun 2016 13:58:38 +0000 (15:58 +0200)
Now that we're using Erlang 18, the preferred atomic ops implementation
for Erlang is its own built-in implementation, so use it instead of
libatomic_ops. BR2_PACKAGE_ERLANG_ARCH_SUPPORTS is added now that
BR2_PACKAGE_LIBATOMIC_OPS_ARCH_SUPPORTS can no longer be used for
checking whether the package can be built.

This fixes autobuilder failures on aarch64 and sparc_v8:

http://autobuild.buildroot.net/results/0cd/0cd22eb74fa29e5a85bf897762e16ab3daf33962/
http://autobuild.buildroot.net/results/688278236e6d5bcd63b7d4413303eb115a38f3a7/
http://autobuild.buildroot.net/results/7875a7425bfe1f43d46c9a1db9f96b54f7a99b19/

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/erlang/Config.in
package/erlang/erlang.mk

index 5fa20288c2dc4f675c929ef6dcd09f3607bfb6d1..56cee5411b326425f704d6afc993c9bbe3e8a6dc 100644 (file)
@@ -1,14 +1,20 @@
+config BR2_PACKAGE_ERLANG_ARCH_SUPPORTS
+       bool
+       # see HOWTO/INSTALL.md for Erlang's supported platforms
+       # when using its native atomic ops implementation
+       default y if BR2_i386 || BR2_x86_64 || BR2_powerpc || \
+               BR2_sparc_v9 || BR2_arm || BR2_aarch64
+
 comment "erlang needs a toolchain w/ dynamic library"
        depends on BR2_USE_MMU # fork()
-       depends on BR2_PACKAGE_LIBATOMIC_OPS_ARCH_SUPPORTS
+       depends on BR2_PACKAGE_ERLANG_ARCH_SUPPORTS
        depends on BR2_STATIC_LIBS
 
 config BR2_PACKAGE_ERLANG
        bool "erlang"
        depends on BR2_USE_MMU # fork()
        depends on !BR2_STATIC_LIBS
-       depends on BR2_PACKAGE_LIBATOMIC_OPS_ARCH_SUPPORTS
-       select BR2_PACKAGE_LIBATOMIC_OPS
+       depends on BR2_PACKAGE_ERLANG_ARCH_SUPPORTS
        help
          Erlang is a programming language used to build massively scalable
          soft real-time systems with requirements on high availability.
index ff4452f68d61d75e636bcfad2da5c8a03a82ce4a..6efffde498de540b12c5d474f4ef2cb8d432d8da 100644 (file)
@@ -30,9 +30,6 @@ ERLANG_CONF_ENV += erl_xcomp_sysroot=$(STAGING_DIR)
 
 ERLANG_CONF_OPTS = --without-javac
 
-ERLANG_DEPENDENCIES += libatomic_ops
-ERLANG_CONF_OPTS += --with-libatomic_ops=$(STAGING_DIR)/usr LIBS=-latomic_ops
-
 # erlang uses openssl for all things crypto. Since the host tools (such as
 # rebar) uses crypto, we need to build host-erlang with support for openssl.
 HOST_ERLANG_DEPENDENCIES = host-openssl