Fix autotools instalation with symbols
authorPaulius Zaleckas <paulius.zaleckas@gmail.com>
Tue, 30 Mar 2010 15:20:55 +0000 (17:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 30 Mar 2010 15:23:23 +0000 (17:23 +0200)
Closes #1447

When installing without symbols install-strip is used,
with symbols - install-exec.
Since install-exec installs only executables, we should use
simple install, to install other needed files also
(like files in /usr/shared) as install-strip does.

Signed-off-by: Paulius Zaleckas <paulius.zaleckas@gmail.com>
Acked-by: Lionel Landwerlin <llandwerlin@gmail.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Makefile.autotools.in

diff --git a/CHANGES b/CHANGES
index 8845b169341b234ea64f00f21ae46a90f7e0e807..0a3a87adf69677d8b80ffa6442ba29430b57e564 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -27,6 +27,7 @@
        #1303: Add librsync package
        #1345: Bump pppd to 2.4.5 and convert to Makefile.autotools.in
        #1441: Add binutils 2.20.1
+       #1447: Package installation on target with debug symbols is broken
 
 2010.02, Release February 26th, 2010:
 
index 7114bbab3995ff50d52ec38cfffee41a94293765..a8dd0511ffa154e43f88916bb1a8d3125da4d865 100644 (file)
@@ -60,7 +60,7 @@ $(2)_LIBTOOL_PATCH            ?= YES
 $(2)_USE_CONFIG_CACHE           ?= $(if $(BR2_CONFIG_CACHE),YES,NO)
 $(2)_INSTALL_STAGING_OPT       ?= DESTDIR=$$(STAGING_DIR) install
 ifeq ($(BR2_ENABLE_DEBUG),y)
-$(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install-exec
+$(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install
 else
 $(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install-strip
 endif