gcc: remove stray bfin --with-cpu exclusion
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 24 Mar 2015 12:15:06 +0000 (09:15 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Mar 2015 20:40:24 +0000 (21:40 +0100)
We no longer support an internal bfin toolchain hence it's dead code.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gcc/gcc.mk

index b5d2ddba1ec862305dfb6753fa7f961939d902e4..24fd7b8778c3e16ed3b49fdfd8166262a202db5c 100644 (file)
@@ -186,8 +186,6 @@ endif
 ifneq ($(call qstrip,$(BR2_GCC_TARGET_ABI)),)
 HOST_GCC_COMMON_CONF_OPTS += --with-abi=$(BR2_GCC_TARGET_ABI)
 endif
-# GCC doesn't support --with-cpu for bfin
-ifeq ($(BR2_bfin),)
 ifneq ($(call qstrip,$(BR2_GCC_TARGET_CPU)),)
 ifneq ($(call qstrip,$(BR2_GCC_TARGET_CPU_REVISION)),)
 HOST_GCC_COMMON_CONF_OPTS += --with-cpu=$(call qstrip,$(BR2_GCC_TARGET_CPU)-$(BR2_GCC_TARGET_CPU_REVISION))
@@ -195,7 +193,6 @@ else
 HOST_GCC_COMMON_CONF_OPTS += --with-cpu=$(call qstrip,$(BR2_GCC_TARGET_CPU))
 endif
 endif
-endif
 
 GCC_TARGET_FPU = $(call qstrip,$(BR2_GCC_TARGET_FPU))
 ifneq ($(GCC_TARGET_FPU),)