ffmpeg: enable x264 support
authorDavid du Colombier <0intro@gmail.com>
Sun, 5 Oct 2014 16:29:57 +0000 (18:29 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 7 Oct 2014 20:59:08 +0000 (22:59 +0200)
Signed-off-by: David du Colombier <0intro@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/ffmpeg.mk

index 1af47a61c9c8a5030d3e4aef6ed0e4b3ead1e12d..af4e1f66680c73937554911f27dfddc31a8cfafd 100644 (file)
@@ -229,6 +229,13 @@ else
 FFMPEG_CONF_OPTS += --disable-libvpx
 endif
 
+ifeq ($(BR2_PACKAGE_X264)$(BR2_PACKAGE_FFMPEG_GPL),yy)
+FFMPEG_CONF_OPTS += --enable-libx264
+FFMPEG_DEPENDENCIES += x264
+else
+FFMPEG_CONF_OPTS += --disable-libx264
+endif
+
 ifeq ($(BR2_X86_CPU_HAS_MMX),y)
 FFMPEG_CONF_OPTS += --enable-yasm
 FFMPEG_DEPENDENCIES += host-yasm