package/libcpprestsdk: work around gcc bug 85180
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Tue, 21 May 2019 13:39:30 +0000 (15:39 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 May 2019 20:01:39 +0000 (22:01 +0200)
With Microblaze Gcc version < 8.x the build hangs due to gcc bug
85180: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85180. The bug
shows up when building libcpprestsdk with optimization but not when
building with -O0. To work around this, if
BR2_TOOLCHAIN_HAS_GCC_BUG_85180=y we force using -O0.

Fixes:

  http://autobuild.buildroot.net/results/7065e14917a8bbc0faf21b29183ac55b6c800ee3/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
[Thomas: tweak CFLAGS logic, improve commit log]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libcpprestsdk/libcpprestsdk.mk

index e8dddeddd7ce8d6d9bb257910115e3d35d74cb77..10b5934d059cf11e72cfd9d4f59a327bef9b4abf 100644 (file)
@@ -18,8 +18,10 @@ LIBCPPRESTSDK_CONF_OPTS += \
        -DBoost_USE_STATIC_RUNTIME=ON
 endif
 
+LIBCPPRESTSDK_CXXFLAGS = $(TARGET_CXXFLAGS)
+
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
-LIBCPPRESTSDK_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -latomic"
+LIBCPPRESTSDK_CXXFLAGS += -latomic
 endif
 
 ifeq ($(BR2_PACKAGE_BROTLI),y)
@@ -36,4 +38,10 @@ else
 LIBCPPRESTSDK_CONF_OPTS += -DCPPREST_EXCLUDE_WEBSOCKETS=ON
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
+LIBCPPRESTSDK_CXXFLAGS += -O0
+endif
+
+LIBCPPRESTSDK_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(LIBCPPRESTSDK_CXXFLAGS)"
+
 $(eval $(cmake-package))