Revert "package/janet: add -std=c99 to CFLAGS"
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 13 Mar 2021 09:59:07 +0000 (10:59 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 14 Mar 2021 13:03:24 +0000 (14:03 +0100)
This reverts commit b5e8f1c1475b46c8d9b7159aafe983e72d329d29. Indeed,
this commit does not fix the build failure as c_std=c99 is already set
in default_options in meson.build.

The issue is that this parameter is not used for native executables
since meson 0.51.

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/janet/janet.mk

index ea042221d8ce34ba778db71b57fb593b6dbb2257..7243d60c011ddb4929e934a8554de8e1a8175ffd 100644 (file)
@@ -8,8 +8,8 @@ JANET_VERSION = 1.15.0
 JANET_SITE = $(call github,janet-lang,janet,v$(JANET_VERSION))
 JANET_LICENSE = MIT
 JANET_LICENSE_FILES = LICENSE
+
 JANET_INSTALL_STAGING = YES
-JANET_CFLAGS = $(TARGET_CFLAGS) -std=c99
 
 ifeq ($(BR2_STATIC_LIBS),y)
 JANET_CONF_OPTS += -Ddynamic_modules=false