package: fix bootloader building
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 30 Sep 2011 18:45:56 +0000 (20:45 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 Oct 2011 18:55:55 +0000 (20:55 +0200)
The changes in e055aea216cff4d12cf55eab2e35ca1459edaa91 and
0849e8193ef429f29945b8c2a54eafc8635e0969 have broken the bootloader
support.

This is because the 'pkgparentdir' macro returns the string 'boot/'
for bootloaders, while the GENTARGETS_INNER macro was testing this
against 'boot' to know if the configuration option to check for this
package is BR2_PACKAGE_* or BR2_TARGET_*.

So, instead of testing against 'boot', we test against 'boot/'.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.package.in

index 353ba72a0331386186c37d4c157555648ff6af72..b5ef57bb19c708aadffed72ba361af0d5b3e406a 100644 (file)
@@ -637,7 +637,7 @@ $$($(2)_TARGET_DIRCLEAN):           PKG=$(2)
 # kernel case, the bootloaders case, and the normal packages case.
 ifeq ($(1),linux)
 $(2)_KCONFIG_VAR = BR2_LINUX_KERNEL
-else ifeq ($(4),boot)
+else ifeq ($(4),boot/)
 $(2)_KCONFIG_VAR = BR2_TARGET_$(2)
 else
 $(2)_KCONFIG_VAR = BR2_PACKAGE_$(2)