Makefile: move filesystem stuff after u-boot build again
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 May 2010 14:19:11 +0000 (16:19 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 21 May 2010 14:19:11 +0000 (16:19 +0200)
Otherwise u-boot tools / kernel modules are only added to target AFTER
the filesystems are built.

Long term u-boot/kernel stuff should get splitted from target/device,
but this is the safest solution for now.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
target/Makefile.in

index a4bf4b570e9fcd73bcfca7e60d3d485d0b9f825c..d59ea45be68fa791e6f844016c6aa9855f245dd7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -320,8 +320,6 @@ ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
 TARGETS+=target-purgelocales
 endif
 
-include fs/common.mk
-
 # target stuff is last so it can override anything else
 include target/Makefile.in
 
index afe96a7f058a68d372be1148a36f3edd242c7a26..ffcdbb64ed6d97f7784fe86e02f14ae20659361b 100644 (file)
@@ -62,6 +62,8 @@ ifeq ($(BR2_TARGET_UBOOT),y)
 include target/u-boot/Makefile.in
 endif
 
+include fs/common.mk
+
 # kernel rules
 # We already did add the kernel target to TARGETS and now just pull in the rules
 # to actually build this target.