package/hostapd: enable Linux ioctls for VLANs
authorSergey Matyukevich <geomatsi@gmail.com>
Sat, 28 Sep 2019 17:36:30 +0000 (20:36 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Fri, 11 Oct 2019 21:38:37 +0000 (23:38 +0200)
Hostapd v2.9 follows the approach taken by bridge-utils and attempts
to use new bridge ioctls whenever possible. New bridge calls are
enabled in hostapd build using NEED_LINUX_IOCTL configuration option.
That switch is enabled for all the practical configurations excluding
wired driver. However it is required to support dynamic VLANs in
any configuration.

Enable NEED_LINUX_IOCTL hostapd configuration option whenever
dynamic VLANs support is requested in buildroot.

Fixes:
http://autobuild.buildroot.net/results/71a/71aa92578622a266b4bed92b66a65438bc32cbd6

Signed-off-by: Sergey Matyukevich <geomatsi@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/hostapd/hostapd.mk

index 4a493cb9b2600d819f72ba18671707f89865cb38..0e5e5b2962fb3dbcfab3996ae6c252871517f1df 100644 (file)
@@ -96,6 +96,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_HOSTAPD_VLAN_DYNAMIC),y)
 HOSTAPD_CONFIG_ENABLE += CONFIG_FULL_DYNAMIC_VLAN
+HOSTAPD_CONFIG_SET += NEED_LINUX_IOCTL
 endif
 
 ifeq ($(BR2_PACKAGE_HOSTAPD_VLAN_NETLINK),y)