wvstreams: Pass -fPIC to CFLAGS when building PIC objects
authorMarkos Chandras <markos.chandras@imgtec.com>
Thu, 20 Jun 2013 14:14:10 +0000 (15:14 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Jun 2013 15:08:18 +0000 (17:08 +0200)
The argp bundled dependency which is linked to the libwvutils.so
shared library, wasn't built with -fPIC.
MIPS will refuce to link a non-PIC library with a shared one.

We fix this problem by appending -fPIC to CFLAGS and build all the
shared objects with -fPIC.

[Peter: use +=]
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/wvstreams/wvstreams.mk

index 65f48d4037fae5c0cc87db1109e65ee034397eba..b4f7d8929707016fa6d8b20215db81c105448f2f 100644 (file)
@@ -27,6 +27,10 @@ WVSTREAMS_CONF_OPT += \
 # needed for openssl detection when statically linking (as ssl needs lz)
 WVSTREAMS_CONF_ENV += LIBS=-lz
 
+ifneq ($(BR2_PREFER_STATIC_LIB),y)
+       WVSTREAMS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -fPIC"
+endif
+
 ifeq ($(BR2_PACKAGE_DBUS),y)
        WVSTREAMS_DEPENDENCIES += dbus
        WVSTREAMS_CONF_OPT += --with-dbus