python-remi: new package
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Fri, 2 Feb 2018 21:42:05 +0000 (22:42 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Feb 2018 09:49:46 +0000 (10:49 +0100)
Remi is a GUI library for Python applications which transpiles an
application's interface into HTML to be rendered in a web browser.
This removes platform-specific dependencies and lets you easily
develop cross-platform applications in Python!

https://github.com/dddomodossola/remi/tree/master

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/python-remi/Config.in [new file with mode: 0644]
package/python-remi/python-remi.hash [new file with mode: 0644]
package/python-remi/python-remi.mk [new file with mode: 0644]

index 93b631269e32a74c97cd995150dc1d8293956fd7..4f2c84758ebb6e1963070aa389c4b5bf87e13e88 100644 (file)
@@ -754,6 +754,7 @@ F:  package/libusbgx/
 F:     package/python-cheetah/
 F:     package/python-markdown/
 F:     package/python-pyqt/
+F:     package/python-remi/
 F:     package/python-sip/
 
 N:     Henrique Camargo <henrique@henriquecamargo.com>
index 84b5ba4ce722a40217bc7351bc06a4c879478fc3..9cd5d9c087418fd8df2794d8c1fd3e90506f031d 100644 (file)
@@ -888,6 +888,7 @@ menu "External python modules"
        source "package/python-pyyaml/Config.in"
        source "package/python-pyzmq/Config.in"
        source "package/python-raven/Config.in"
+       source "package/python-remi/Config.in"
        source "package/python-requests/Config.in"
        source "package/python-requests-oauthlib/Config.in"
        source "package/python-requests-toolbelt/Config.in"
diff --git a/package/python-remi/Config.in b/package/python-remi/Config.in
new file mode 100644 (file)
index 0000000..68d0a92
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_REMI
+       bool "python-remi"
+       help
+         Remi is a GUI library for Python applications which transpiles an
+         application's interface into HTML to be rendered in a web browser.
+         This removes platform-specific dependencies and lets you easily
+         develop cross-platform applications in Python!
+
+         https://github.com/dddomodossola/remi/tree/master
diff --git a/package/python-remi/python-remi.hash b/package/python-remi/python-remi.hash
new file mode 100644 (file)
index 0000000..e3df6cb
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256 69ab3f7438de76708bfc40396f791b76452f84bb8bca6dafbdaca510c17e9526  python-remi-v1.0.tar.gz
+sha256 bc198f9846c1da3a1c1b1fa2b12909b021365d1e7fe9b4039245edfcec3b7f7f  LICENSE
diff --git a/package/python-remi/python-remi.mk b/package/python-remi/python-remi.mk
new file mode 100644 (file)
index 0000000..6514118
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+# 
+# python-remi
+#
+################################################################################
+
+PYTHON_REMI_VERSION = v1.0
+PYTHON_REMI_SITE = $(call github,dddomodossola,remi,$(PYTHON_REMI_VERSION))
+PYTHON_REMI_LICENSE = Apache-2.0
+PYTHON_REMI_LICENSE_FILES = LICENSE
+PYTHON_REMI_SETUP_TYPE = setuptools
+
+$(eval $(python-package))
+