u-boot: add 2011.03 release
authorLuca Ceresoli <luca@lucaceresoli.net>
Fri, 8 Apr 2011 14:46:23 +0000 (16:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Apr 2011 21:37:43 +0000 (23:37 +0200)
Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/u-boot/Config.in
boot/u-boot/u-boot.mk

index 3ba1ef3a92d79fc0277c4d0aaf6fd679f5c0d3bf..00a4a5f246af3ded6f4974e29a1377b5d7ac1ff0 100644 (file)
@@ -12,10 +12,13 @@ config BR2_TARGET_UBOOT_BOARDNAME
 
 choice
        prompt "U-Boot Version"
-       default BR2_TARGET_UBOOT_2010_12
+       default BR2_TARGET_UBOOT_2011_03
        help
          Select the specific U-Boot version you want to use
 
+config BR2_TARGET_UBOOT_2011_03
+       bool "2011.03"
+
 config BR2_TARGET_UBOOT_2010_12
        bool "2010.12"
 
@@ -42,6 +45,7 @@ endif
 
 config BR2_TARGET_UBOOT_VERSION
        string
+       default "2011.03"       if BR2_TARGET_UBOOT_2011_03
        default "2010.12"       if BR2_TARGET_UBOOT_2010_12
        default "2010.09"       if BR2_TARGET_UBOOT_2010_09
        default "2010.06"       if BR2_TARGET_UBOOT_2010_06
index ff3f65e96a7c51e8bb362d36c3c5e0b7a271ab1f..047f2c87e2a9770261fec72789a35152213ebe12 100644 (file)
@@ -11,7 +11,7 @@ U_BOOT_BOARD_NAME:=$(call qstrip,$(BR2_TARGET_UBOOT_BOARDNAME))
 # pick some random stable U-Boot version that will be used just to
 # build mkimage.
 ifeq ($(U_BOOT_VERSION),)
-U_BOOT_VERSION=2010.12
+U_BOOT_VERSION=2011.03
 endif
 
 ifeq ($(U_BOOT_VERSION),custom)