Remove all TARGET_DEVICE_TABLE definitions
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Apr 2010 02:33:30 +0000 (04:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Apr 2010 02:36:23 +0000 (04:36 +0200)
We have a special case for Xtensa, which was patching the generic
device_table.txt. Instead of doing this, we just keep a copy of the
device table, specific to Xtensa, with Xtensa specifities. The fact
that the patch wasn't applying anymore on the generic device table is
a sign that the existing approach wasn't working anyway.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
target/device/Atmel/Makefile.in
target/device/Atmel/atngw100-base/Makefile.in
target/device/Atmel/atngw100/Makefile.in
target/device/Atmel/atstk1005/Makefile.in
target/device/Atmel/atstk100x/Makefile.in
target/device/KwikByte/kb9202/Makefile.in
target/device/valka/Makefile.in
target/device/xtensa/Makefile.in
target/device/xtensa/device_table.diff [deleted file]
target/device/xtensa/device_table.txt [new file with mode: 0644]
target/generic/Makefile.in

index bf7a2d1083f1dd99f73cdc8ccf2d4a75f98d177f..c5dfffd70b68ffa5590c73bc71111e03bbedf757 100644 (file)
@@ -8,7 +8,6 @@ BOARD_PATH:=$(call qstrip,$(BR2_BOARD_PATH))
 
 ATMEL_TARGET:=$(ATMEL_PATH)/root
 TARGET_SKELETON:=$(ATMEL_TARGET)/target_skeleton
-TARGET_DEVICE_TABLE:=$(ATMEL_TARGET)/device_table.txt
 TARGET_SKELETON_LINKS:=$(ATMEL_TARGET)/skel.tar.gz
 
 ifeq ($(BR2_avr32),y)
index 467951f08020739a9a327d8f557db0879d6e217a..c2f2969700788d2e81cc6578a13b2e21810b0fa3 100644 (file)
@@ -1,5 +1,4 @@
 ifeq ($(BR2_TARGET_AVR32_ATNGW100_BASE),y)
 UBOOT_BOARD_NAME:=atngw100
 TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
 endif
index 3c34d8d4a9cbd7d9e82efe3e5b21e17e174d909d..7e02d8e831189fbd873a7e3aad5475cd99b9ab16 100644 (file)
@@ -1,5 +1,4 @@
 ifeq ($(BR2_TARGET_AVR32_ATNGW100),y)
 UBOOT_BOARD_NAME:=atngw100
 TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
 endif
index 4c3aadffba067c2bd5ec1e4068f2a12747d6b78e..84b31070de945a969f234e8f347a8f3f8d6d42cf 100644 (file)
@@ -1,4 +1,3 @@
 ifeq ($(strip $(BR2_TARGET_AVR32_ATSTK1005)),y)
 TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
 endif
index e9dd4dc428e9a5e413ab0a6d643cc0924afc6595..395c74a6e4a6ae741b03b6e1dc6dd33ec87560ed 100644 (file)
@@ -1,5 +1,4 @@
 ifeq ($(strip $(BR2_TARGET_AVR32_ATSTK1002)),y)
 UBOOT_BOARD_NAME:=atstk1002
 TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
 endif
index 5d743cec552593f9b4b5a182b8221f66fe545368..0048dcc3a5c251bf75c2ea7025017f4b4d8da214 100644 (file)
@@ -1,4 +1,3 @@
 BOARD_PATH=target/device/KwikByte/kb9202
 
 TARGET_SKELETON=$(BOARD_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(BOARD_PATH)/device_table.txt
index 01422465ef66c32382a18b2df43bf6790ce484d4..fec4d88d5c187c98a82cfd5bedc24f0867847d9f 100644 (file)
@@ -2,7 +2,6 @@ ifeq ($(BR2_TARGET_VALKA),y)
 VALKA_PATH= target/device/valka
 
 TARGET_SKELETON=$(VALKA_PATH)/target_skeleton
-TARGET_DEVICE_TABLE=$(VALKA_PATH)/device_table.txt
 KERNEL_HEADERS_PATCH_DIR=target/device/Atmel/arch-avr32/kernel-headers-2.6.28.2
 
 valka_status:
@@ -10,7 +9,6 @@ valka_status:
        @echo VALKA_PATH = $(VALKA_PATH)
        @echo BOARD_NAME = $(BR_BOARD_NAME)
        @echo TARGET_SKELETON = $(TARGET_SKELETON)
-       @echo TARGET_DEVICE_TABLE = $(TARGET_DEVICE_TABLE)
        @echo BR2_PACKAGE_BUSYBOX_CONFIG = $(BR2_PACKAGE_BUSYBOX_CONFIG)
        @echo BR2_PACKAGE_LINUX_KCONFIG = $(BR2_PACKAGE_LINUX_KCONFIG)
        @echo "*****************************************************************"
index 7c95c239b7c87c290feaa03c20e74d8f1413d473..f878a822a737bcb6c014e5f71e5e1c98a0f676cc 100644 (file)
@@ -6,12 +6,4 @@ ifeq ($(strip $(BR2_TARGET_XTENSA_XTAV60)),y)
 TARGET_SKELETON_PATCH:=target/device/xtensa
 endif
 
-#  Custom device table patch used when targeting ISS:
-OLD_TARGET_DEVICE_TABLE := $(TARGET_DEVICE_TABLE)
-TARGET_DEVICE_TABLE := target/device/xtensa/device_table.txt
-makedevs:
-       @echo "Applying patch to $(TARGET_DEVICE_TABLE)"
-       cp -f $(OLD_TARGET_DEVICE_TABLE) $(TARGET_DEVICE_TABLE)
-       patch -p1 -g 0 < target/device/xtensa/device_table.diff
-
 endif
diff --git a/target/device/xtensa/device_table.diff b/target/device/xtensa/device_table.diff
deleted file mode 100644 (file)
index 12f6825..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/target/generic/device_table.txt b/target/generic/device_table.txt
-index f4b16ba..b87bf69 100644
---- a/target/device/xtensa/device_table.txt
-+++ b/target/device/xtensa/device_table.txt
-@@ -169,3 +169,5 @@
- #/dev/mcd      b       640     0       0       23      0       0       0       
- #/dev/optcd    b       640     0       0       17      0       0       0       
-+/dev/simdisk0        b      640      0       0       240     0       0       0
-+/dev/simdisk1        b      640      0       0       240     1       0       0
diff --git a/target/device/xtensa/device_table.txt b/target/device/xtensa/device_table.txt
new file mode 100644 (file)
index 0000000..d0c7467
--- /dev/null
@@ -0,0 +1,189 @@
+# When building a target filesystem, it is desirable to not have to
+# become root and then run 'mknod' a thousand times.  Using a device 
+# table you can create device nodes and directories "on the fly".
+#
+# This is a sample device table file for use with genext2fs.  You can
+# do all sorts of interesting things with a device table file.  For
+# example, if you want to adjust the permissions on a particular file
+# you can just add an entry like:
+#   /sbin/foobar        f       2755    0       0       -       -       -       -       -
+# and (assuming the file /sbin/foobar exists) it will be made setuid
+# root (regardless of what its permissions are on the host filesystem.
+# Furthermore, you can use a single table entry to create a many device
+# minors.  For example, if I wanted to create /dev/hda and /dev/hda[0-15]
+# I could just use the following two table entries:
+#   /dev/hda    b       640     0       0       3       0       0       0       -
+#   /dev/hda    b       640     0       0       3       1       1       1       15
+# 
+# Device table entries take the form of:
+# <name>    <type>      <mode>  <uid>   <gid>   <major> <minor> <start> <inc>   <count>
+# where name is the file name,  type can be one of: 
+#       f       A regular file
+#       d       Directory
+#       c       Character special device file
+#       b       Block special device file
+#       p       Fifo (named pipe)
+# uid is the user id for the target file, gid is the group id for the
+# target file.  The rest of the entries (major, minor, etc) apply only 
+# to device special files.
+
+# Have fun
+# -Erik Andersen <andersen@codepoet.org>
+#
+
+#<name>                <type>  <mode>  <uid>   <gid>   <major> <minor> <start> <inc>   <count>
+/dev           d       755     0       0       -       -       -       -       -
+/dev/pts       d       755     0       0       -       -       -       -       -
+/dev/shm       d       755     0       0       -       -       -       -       -
+/tmp           d       1777    0       0       -       -       -       -       -
+/etc           d       755     0       0       -       -       -       -       -
+/home/default  d       2755    1000    1000    -       -       -       -       -
+#<name>                                        <type>  <mode>  <uid>   <gid>   <major> <minor> <start> <inc>   <count>
+/bin/busybox                           f       4755    0       0       -       -       -       -       -
+/etc/shadow                            f       600     0       0       -       -       -       -       -
+/etc/passwd                            f       644     0       0       -       -       -       -       -
+/etc/network/if-up.d                   d       755     0       0       -       -       -       -       -
+/etc/network/if-pre-up.d               d       755     0       0       -       -       -       -       -
+/etc/network/if-down.d                 d       755     0       0       -       -       -       -       -
+/etc/network/if-post-down.d            d       755     0       0       -       -       -       -       -
+/usr/share/udhcpc/default.script       f       755     0       0       -       -       -       -       -
+# uncomment this to allow starting x as non-root
+#/usr/X11R6/bin/Xfbdev         f       4755    0       0       -       -       -       -       -
+# Normal system devices
+/dev/mem       c       640     0       0       1       1       0       0       -
+/dev/kmem      c       640     0       0       1       2       0       0       -
+/dev/null      c       666     0       0       1       3       0       0       -
+/dev/zero      c       666     0       0       1       5       0       0       -
+/dev/random    c       666     0       0       1       8       0       0       -
+/dev/urandom   c       666     0       0       1       9       0       0       -
+/dev/ram       b       640     0       0       1       1       0       0       -
+/dev/ram       b       640     0       0       1       0       0       1       4
+/dev/loop      b       640     0       0       7       0       0       1       2
+/dev/rtc       c       640     0       0       10      135     -       -       -
+/dev/console   c       666     0       0       5       1       -       -       -
+/dev/tty       c       666     0       0       5       0       -       -       -
+/dev/tty       c       666     0       0       4       0       0       1       8
+/dev/ttyp      c       666     0       0       3       0       0       1       10
+/dev/ptyp      c       666     0       0       2       0       0       1       10
+/dev/ptmx      c       666     0       0       5       2       -       -       -
+/dev/ttyP      c       666     0       0       57      0       0       1       4
+/dev/ttyS      c       666     0       0       4       64      0       1       4
+/dev/fb                c       640     0       5       29      0       0       1       4
+#/dev/ttySA    c       666     0       0       204     5       0       1       3
+/dev/psaux     c       666     0       0       10      1       0       0       -
+#/dev/ppp      c       666     0       0       108     0       -       -       -
+/dev/ttyCPM    c       666     0       0       204     46      0       1       4
+/dev/ttyAMA    c       666     0       0       204     64      0       1       4
+/dev/ttySAC    c       666     0       0       204     64      0       1       4
+/dev/ttyPSC    c       666     0       0       204     148     0       1       4
+/dev/ttyUL     c       666     0       0       204     187     0       1       4
+/dev/ttymxc    c       666     0       0       207     16      0       1       3
+
+# Input stuff
+/dev/input             d       755     0       0       -       -       -       -       -
+/dev/input/mice                c       640     0       0       13      63      0       0       -
+/dev/input/mouse       c       660     0       0       13      32      0       1       4
+/dev/input/event       c       660     0       0       13      64      0       1       4
+#/dev/input/js         c       660     0       0       13      0       0       1       4
+
+
+# MTD stuff
+/dev/mtd       c       640     0       0       90      0       0       2       4
+/dev/mtdblock  b       640     0       0       31      0       0       1       4
+
+#Tun/tap driver
+/dev/net       d       755     0       0       -       -       -       -       -
+/dev/net/tun   c       660     0       0       10      200     -       -       -
+
+# Audio stuff
+#/dev/audio    c       666     0       29      14      4       -       -       -
+#/dev/audio1   c       666     0       29      14      20      -       -       -
+#/dev/dsp      c       666     0       29      14      3       -       -       -
+#/dev/dsp1     c       666     0       29      14      19      -       -       -
+#/dev/sndstat  c       666     0       29      14      6       -       -       -
+
+# User-mode Linux stuff
+#/dev/ubda     b       640     0       0       98      0       0       0       -
+#/dev/ubda     b       640     0       0       98      1       1       1       15
+
+# IDE Devices
+/dev/hda       b       640     0       0       3       0       0       0       -
+/dev/hda       b       640     0       0       3       1       1       1       15
+/dev/hdb       b       640     0       0       3       64      0       0       -
+/dev/hdb       b       640     0       0       3       65      1       1       15
+#/dev/hdc      b       640     0       0       22      0       0       0       -
+#/dev/hdc      b       640     0       0       22      1       1       1       15
+#/dev/hdd      b       640     0       0       22      64      0       0       -
+#/dev/hdd      b       640     0       0       22      65      1       1       15
+#/dev/hde      b       640     0       0       33      0       0       0       -
+#/dev/hde      b       640     0       0       33      1       1       1       15
+#/dev/hdf      b       640     0       0       33      64      0       0       -
+#/dev/hdf      b       640     0       0       33      65      1       1       15
+#/dev/hdg      b       640     0       0       34      0       0       0       -
+#/dev/hdg      b       640     0       0       34      1       1       1       15
+#/dev/hdh      b       640     0       0       34      64      0       0       -
+#/dev/hdh      b       640     0       0       34      65      1       1       15
+
+# SCSI Devices
+/dev/sda       b       640     0       0       8       0       0       0       -
+/dev/sda       b       640     0       0       8       1       1       1       15
+/dev/sdb       b       640     0       0       8       16      0       0       -
+/dev/sdb       b       640     0       0       8       17      1       1       15
+#/dev/sdc      b       640     0       0       8       32      0       0       -
+#/dev/sdc      b       640     0       0       8       33      1       1       15
+#/dev/sdd      b       640     0       0       8       48      0       0       -
+#/dev/sdd      b       640     0       0       8       49      1       1       15
+#/dev/sde      b       640     0       0       8       64      0       0       -
+#/dev/sde      b       640     0       0       8       65      1       1       15
+#/dev/sdf      b       640     0       0       8       80      0       0       -
+#/dev/sdf      b       640     0       0       8       81      1       1       15
+#/dev/sdg      b       640     0       0       8       96      0       0       -
+#/dev/sdg      b       640     0       0       8       97      1       1       15
+#/dev/sdh      b       640     0       0       8       112     0       0       -
+#/dev/sdh      b       640     0       0       8       113     1       1       15
+#/dev/sg       c       640     0       0       21      0       0       1       15
+#/dev/scd      b       640     0       0       11      0       0       1       15
+#/dev/st       c       640     0       0       9       0       0       1       8
+#/dev/nst      c       640     0       0       9       128     0       1       8
+#/dev/st       c       640     0       0       9       32      1       1       4
+#/dev/st       c       640     0       0       9       64      1       1       4
+#/dev/st       c       640     0       0       9       96      1       1       4
+
+# USB block devices (ub driver)
+/dev/uba       b       640     0       0       180     0       0       0       -
+/dev/uba       b       640     0       0       180     1       1       1       6
+/dev/ubb       b       640     0       0       180     8       0       0       -
+/dev/ubb       b       640     0       0       180     65      1       1       6
+
+# Floppy disk devices
+#/dev/fd       b       640     0       0       2       0       0       1       2
+#/dev/fd0d360  b       640     0       0       2       4       0       0       -
+#/dev/fd1d360  b       640     0       0       2       5       0       0       -
+#/dev/fd0h1200 b       640     0       0       2       8       0       0       -
+#/dev/fd1h1200 b       640     0       0       2       9       0       0       -
+#/dev/fd0u1440 b       640     0       0       2       28      0       0       -
+#/dev/fd1u1440 b       640     0       0       2       29      0       0       -
+#/dev/fd0u2880 b       640     0       0       2       32      0       0       -
+#/dev/fd1u2880 b       640     0       0       2       33      0       0       -
+
+# All the proprietary cdrom devices in the world
+#/dev/aztcd    b       640     0       0       29      0       0       0       -
+#/dev/bpcd     b       640     0       0       41      0       0       0       -
+#/dev/capi20   c       640     0       0       68      0       0       1       2
+#/dev/cdu31a   b       640     0       0       15      0       0       0       -
+#/dev/cdu535   b       640     0       0       24      0       0       0       -
+#/dev/cm206cd  b       640     0       0       32      0       0       0       -
+#/dev/sjcd     b       640     0       0       18      0       0       0       -
+#/dev/sonycd   b       640     0       0       15      0       0       0       -
+#/dev/gscd     b       640     0       0       16      0       0       0       -
+#/dev/sbpcd    b       640     0       0       25      0       0       0       -
+#/dev/sbpcd    b       640     0       0       25      0       0       1       4
+#/dev/mcd      b       640     0       0       23      0       0       0       -
+#/dev/optcd    b       640     0       0       17      0       0       0       -
+
+# I2C device nodes
+/dev/i2c-      c       666     0       0       89      0       0       1       4
+
+# Xtensa special devices
+/dev/simdisk0        b      640      0       0       240     0       0       0
+/dev/simdisk1        b      640      0       0       240     1       0       0
index f77f9698c81b27536a5e3feb9a5681ec93cc1b6c..9a56f760401ca87366c4fc6193fad8aab634eae6 100644 (file)
@@ -1,10 +1,8 @@
 # Default target skeleton stuff, may be overridden
 TARGET_SKELETON=target/generic/target_skeleton
-TARGET_DEVICE_TABLE=target/generic/device_table.txt
 
 ifeq ($(BR2_PACKAGE_BUSYBOX_SKELETON),y)
 TARGET_SKELETON=target/generic/target_busybox_skeleton
-TARGET_DEVICE_TABLE=target/generic/mini_device_table.txt
 endif
 
 TARGET_GENERIC_HOSTNAME:=$(call qstrip,$(BR2_TARGET_GENERIC_HOSTNAME))