package/harfbuzz: work around arc gcc10 bug
authorGiulio Benetti <giulio.benetti@benettiengineering.com>
Wed, 8 Sep 2021 21:57:40 +0000 (23:57 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 11 Sep 2021 15:25:57 +0000 (17:25 +0200)
With BR2_GCC_VERSION_ARC=y(arc gcc10) harfbuzz package exhibits a gcc bug
that makes build to fail. This bug is found only in official arc gcc10
provided by Synopsis, so we can't use the BR2_TOOLCHAIN_HAS_GCC_BUG_
approach since bug can't be even filed in gcc bugzilla.
To work around this, if BR2_GCC_VERSION_ARC=y we force using -O0.

Fixes:
http://autobuild.buildroot.net/results/e4d/e4da9ba40c8f4567601d404e20dd6a0b322210c2/

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/harfbuzz/harfbuzz.mk

index d0595d6416927d0220f7b1326686d205ecca58e4..70c1e1f7e6b9d3d376fc89f63cc57367e70c5535 100644 (file)
@@ -94,5 +94,9 @@ ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
 HARFBUZZ_CXXFLAGS += $(TARGET_CXXFLAGS) -DHB_NO_MT
 endif
 
+ifeq ($(BR2_GCC_VERSION_ARC),y)
+HARFBUZZ_CXXFLAGS += -O0
+endif
+
 $(eval $(meson-package))
 $(eval $(host-meson-package))