package/imagemagick: add optional libzip support
authorPeter Seiderer <ps.report@gmx.net>
Fri, 19 Feb 2021 23:02:53 +0000 (00:02 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 26 Feb 2021 23:38:42 +0000 (00:38 +0100)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/imagemagick/imagemagick.mk

index bc3040769fa54223cba1f0d72c34cd1b553ce12c..48892fd4497ad16f4c75c06537956af30b60c30c 100644 (file)
@@ -103,6 +103,13 @@ else
 IMAGEMAGICK_CONF_OPTS += --without-xml
 endif
 
+ifeq ($(BR2_PACKAGE_LIBZIP),y)
+IMAGEMAGICK_CONF_OPTS += --with-zip
+IMAGEMAGICK_DEPENDENCIES += libzip
+else
+IMAGEMAGICK_CONF_OPTS += --without-zip
+endif
+
 ifeq ($(BR2_PACKAGE_PANGO),y)
 IMAGEMAGICK_CONF_OPTS += --with-pango
 IMAGEMAGICK_DEPENDENCIES += pango
@@ -170,6 +177,7 @@ HOST_IMAGEMAGICK_CONF_OPTS = \
        --without-raqm \
        --without-wmf \
        --without-x \
+       --without-zip \
        --without-bzlib \
        --without-fftw \
        --without-lcms \