package/liquid-dsp: drop support for fftw-double and fftw-long-double
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 21 Jan 2019 13:51:11 +0000 (14:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 5 Feb 2019 20:06:18 +0000 (21:06 +0100)
liquid-dsp has the following code:

So, if it uses the external fftw library, it can only use the fftwf
variant, i.e the fftw-single variant. Otherwise, it uses its internal
FFT library.

There is no way for liquid-dsp to use fftw-double or fftw-long-double.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/liquid-dsp/liquid-dsp.mk

index db67893844d56854f0ed456da5cee1bf8b4c9ba3..1f645bf33ac495a0e22afc71ece84c170aa567f1 100644 (file)
@@ -40,16 +40,6 @@ ifeq ($(BR2_powerpc)$(BR2_powerpc64)$(BR2_powerpc64le),y)
 LIQUID_DSP_CONF_OPTS += --enable-simdoverride
 endif
 
-ifeq ($(BR2_PACKAGE_FFTW_PRECISION_DOUBLE),y)
-LIQUID_DSP_LDFLAGS += -lfftw3
-LIQUID_DSP_DEPENDENCIES += fftw
-endif
-
-ifeq ($(BR2_PACKAGE_FFTW_PRECISION_LONG_DOUBLE),y)
-LIQUID_DSP_LDFLAGS += -lfftw3l
-LIQUID_DSP_DEPENDENCIES += fftw
-endif
-
 LIQUID_DSP_CONF_OPTS += \
        CFLAGS="$(LIQUID_DSP_CFLAGS)" \
        LDFLAGS="$(LIQUID_DSP_LDFLAGS)"