mpd: add twolame support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 9 Jul 2014 18:12:08 +0000 (15:12 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 10 Jul 2014 09:34:54 +0000 (11:34 +0200)
Now that there's a twolame package we can add support for it in mpd.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/Config.in
package/mpd/mpd.mk

index 489b49df29b88ac99870927fd07c1a18d79ba36f..b49112636205652d4900f478b86f20787e3beea7 100644 (file)
@@ -184,6 +184,16 @@ config BR2_PACKAGE_MPD_TREMOR
          Enable vorbis input support.
          Select this if you want to play back OGG files on softfloat targets.
 
+config BR2_PACKAGE_MPD_TWOLAME
+       bool "twolame"
+       depends on BR2_LARGEFILE # twolame -> libsndfile
+       select BR2_PACKAGE_TWOLAME
+       help
+         Enable TwoLAME mp2 encoding.
+
+comment "twolame support needs a toolchain w/ largefile"
+        depends on !BR2_LARGEFILE
+
 config BR2_PACKAGE_MPD_VORBIS
        bool "vorbis"
        select BR2_PACKAGE_LIBOGG
index 2f0b37ed2feda98a36ce99f2016890e3a4287332..21eb08e123920e3084e21ba54977dfb34f853232 100644 (file)
@@ -132,6 +132,11 @@ MPD_DEPENDENCIES += tremor
 MPD_CONF_OPT += --with-tremor
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_TWOLAME),y)
+MPD_DEPENDENCIES += twolame
+MPD_CONF_OPT += --enable-twolame-encoder
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_WAVPACK),y)
 MPD_DEPENDENCIES += wavpack
 else