fs/ext2: allow reserving zero block for root
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 3 Jul 2017 22:50:59 +0000 (00:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 06:47:57 +0000 (08:47 +0200)
The previous default, zero, just meant "use the default value of the
filesystem generator", which happened to be 5% (the traditional value
for all ext-creating tools we've ever seen).

So, change the new default accordingly to 5%.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/ext2/Config.in
fs/ext2/ext2.mk

index a1e3647a14973fe309e28dc39368b27866f8dc9b..6f16dde17f93636dcc18751d67928884a747c43d 100644 (file)
@@ -65,7 +65,12 @@ config BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES
 
 config BR2_TARGET_ROOTFS_EXT2_RESBLKS
        int "reserved blocks percentage"
-       default 0
+       default 5
+       help
+         The number of blocks on the filesystem (as a percentage of the
+         total number of blocksi), that are reserved for use by root.
+         Traditionally, this has been 5%, and all ext-related tools still
+         default to reserving 5% when creating a new ext filesystem.
 
 choice
        prompt "Compression method"
index 6a35b33117f81129459c2b410a7352ca343b802d..57058b5fd2983844ba05368818cf3c1af7418046 100644 (file)
@@ -12,9 +12,7 @@ EXT2_OPTS += -i $(BR2_TARGET_ROOTFS_EXT2_INODES)
 
 EXT2_OPTS += -I $(BR2_TARGET_ROOTFS_EXT2_EXTRA_INODES)
 
-ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_RESBLKS)),0)
 EXT2_OPTS += -r $(BR2_TARGET_ROOTFS_EXT2_RESBLKS)
-endif
 
 # qstrip results in stripping consecutive spaces into a single one. So the
 # variable is not qstrip-ed to preserve the integrity of the string value.