package: use variables defined by autoconf.mk
authorNicolas Carrier <nicolas.carrier@orolia.com>
Fri, 25 Oct 2019 18:22:43 +0000 (18:22 +0000)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 4 Feb 2020 13:27:28 +0000 (14:27 +0100)
autoconf.mk defines AUTOCONF and AUTOHEADER variables, use them in packages
using autoconf.
This is a refactoring which shouldn't impact the final behavior.

Signed-off-by: Nicolas Carrier <nicolas.carrier@orolia.com>
Reviewed-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
12 files changed:
package/cups/cups.mk
package/libxmlrpc/libxmlrpc.mk
package/ncftp/ncftp.mk
package/php-amqp/php-amqp.mk
package/php-geoip/php-geoip.mk
package/php-gnupg/php-gnupg.mk
package/php-imagick/php-imagick.mk
package/php-memcached/php-memcached.mk
package/php-ssh2/php-ssh2.mk
package/php-yaml/php-yaml.mk
package/php-zmq/php-zmq.mk
package/socat/socat.mk

index 8ac28b0f14f76a8f5776bc87680f84f06ad9dc08..da6778f30ae5d1fcfb0d45dc2235654f10aa3b76 100644 (file)
@@ -13,7 +13,7 @@ CUPS_INSTALL_STAGING = YES
 
 # Using autoconf, not autoheader, so we cannot use AUTORECONF = YES.
 define CUPS_RUN_AUTOCONF
-       cd $(@D); $(HOST_DIR)/bin/autoconf -f
+       cd $(@D); $(AUTOCONF) -f
 endef
 CUPS_PRE_CONFIGURE_HOOKS += CUPS_RUN_AUTOCONF
 
index 90791bd67125131a82797e6dab369c4869e38cf7..54db9f1f89fb83d69cc30c3565a93582fbab9bc8 100644 (file)
@@ -16,7 +16,7 @@ LIBXMLRPC_MAKE = $(MAKE1)
 
 # Using autoconf, not automake, so we cannot use AUTORECONF = YES.
 define LIBXMLRPC_RUN_AUTOCONF
-       cd $(@D); $(HOST_DIR)/bin/autoconf
+       cd $(@D); $(AUTOCONF)
 endef
 
 LIBXMLRPC_PRE_CONFIGURE_HOOKS += LIBXMLRPC_RUN_AUTOCONF
index c8c8942333a8a929c80931697e29956a238488b0..676a9c58959f7e2145bd1246bb6df67f8484b98b 100644 (file)
@@ -21,7 +21,7 @@ NCFTP_CONF_OPTS = --disable-ccdv
 # We need to pass -I because of the non-standard m4 directory name, and
 # none of the other autotools are used, so the below is the easiest.
 define NCFTP_RUN_AUTOCONF
-       (cd $(@D); $(HOST_DIR)/bin/autoconf -I$(@D)/autoconf_local/)
+       (cd $(@D); $(AUTOCONF) -I$(@D)/autoconf_local/)
 endef
 NCFTP_PRE_CONFIGURE_HOOKS += NCFTP_RUN_AUTOCONF
 
index c808ecdbd697c4b8a6eca928d4825684c4c34289..8f3ba1f9f4190e0adf27a008e5c08773ae723bba 100644 (file)
@@ -16,8 +16,8 @@ PHP_AMQP_LICENSE_FILES = LICENSE
 
 define PHP_AMQP_PHPIZE
        (cd $(@D); \
-               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
-               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               PHP_AUTOCONF=$(AUTOCONF) \
+               PHP_AUTOHEADER=$(AUTOHEADER) \
                $(STAGING_DIR)/usr/bin/phpize)
 endef
 
index 82ecba5816441536b6c35c6e3ba5493502c357a2..8bff564e2dde6555c94d1dcc9fb5b3221bc7feb3 100644 (file)
@@ -16,8 +16,8 @@ PHP_GEOIP_LICENSE_FILES = geoip.c
 
 define PHP_GEOIP_PHPIZE
        (cd $(@D); \
-               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
-               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               PHP_AUTOCONF=$(AUTOCONF) \
+               PHP_AUTOHEADER=$(AUTOHEADER) \
                $(STAGING_DIR)/usr/bin/phpize)
 endef
 
index ae0a781154026923d815e7a58179ed3435d6ca98..8137da4978a7d76e33fe1cdbde9cf06618fce56e 100644 (file)
@@ -16,8 +16,8 @@ PHP_GNUPG_LICENSE_FILES = LICENSE
 
 define PHP_GNUPG_PHPIZE
        (cd $(@D); \
-               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
-               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               PHP_AUTOCONF=$(AUTOCONF) \
+               PHP_AUTOHEADER=$(AUTOHEADER) \
                $(STAGING_DIR)/usr/bin/phpize)
 endef
 
index ca0cbc7492f033fbb0b476d3daf84adab34524e8..a5541b003507e471012da891d2d623a22542e27c 100644 (file)
@@ -16,8 +16,8 @@ PHP_IMAGICK_LICENSE_FILES = LICENSE
 
 define PHP_IMAGICK_PHPIZE
        (cd $(@D); \
-               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
-               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               PHP_AUTOCONF=$(AUTOCONF) \
+               PHP_AUTOHEADER=$(AUTOHEADER) \
                $(STAGING_DIR)/usr/bin/phpize)
 endef
 
index 4607d099f3d0bdc9cb293a4ba2f261c0d69a7a58..67ccc6747a5e4d050f3e9c22f0120f13d140812c 100644 (file)
@@ -18,8 +18,8 @@ PHP_MEMCACHED_LICENSE_FILES = LICENSE fastlz/LICENSE g_fmt.h
 
 define PHP_MEMCACHED_PHPIZE
        (cd $(@D); \
-               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
-               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               PHP_AUTOCONF=$(AUTOCONF) \
+               PHP_AUTOHEADER=$(AUTOHEADER) \
                $(STAGING_DIR)/usr/bin/phpize)
 endef
 
index c9c13010dd2b91580d35aa087f965be6b06c8d61..98453acbcf3daed365baedb441a8f8c1e9a7acab 100644 (file)
@@ -16,8 +16,8 @@ PHP_SSH2_LICENSE_FILES = LICENSE
 
 define PHP_SSH2_PHPIZE
        (cd $(@D); \
-               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
-               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               PHP_AUTOCONF=$(AUTOCONF) \
+               PHP_AUTOHEADER=$(AUTOHEADER) \
                $(STAGING_DIR)/usr/bin/phpize)
 endef
 
index e23d897978664f23fa21d58fe48c38cc138427b3..40f7385c6aa26c52f77fc95e7bdcdccb4251e270 100644 (file)
@@ -16,8 +16,8 @@ PHP_YAML_LICENSE_FILES = LICENSE
 
 define PHP_YAML_PHPIZE
        (cd $(@D); \
-               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
-               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               PHP_AUTOCONF=$(AUTOCONF) \
+               PHP_AUTOHEADER=$(AUTOHEADER) \
                $(STAGING_DIR)/usr/bin/phpize)
 endef
 
index fed71955b61a6b2a2cee15e963530c929b8684dd..892c42130f3882ab70a09d5c65525684a5ff28b5 100644 (file)
@@ -15,8 +15,8 @@ PHP_ZMQ_LICENSE_FILES = LICENSE
 
 define PHP_ZMQ_PHPIZE
        (cd $(@D); \
-               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
-               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               PHP_AUTOCONF=$(AUTOCONF) \
+               PHP_AUTOHEADER=$(AUTOHEADER) \
                $(STAGING_DIR)/usr/bin/phpize)
 endef
 
index 3807d45379fceb74163aa4c097934becc888fc87..4bfdc18f919206b74cac98fc109e863e168dd1bf 100644 (file)
@@ -37,7 +37,7 @@ SOCAT_CONF_OPTS += --disable-openssl
 endif
 
 define SOCAT_RUN_AUTOCONF
-       (cd $(@D); $(HOST_DIR)/bin/autoconf)
+       (cd $(@D); $(AUTOCONF))
 endef
 
 SOCAT_PRE_CONFIGURE_HOOKS += SOCAT_RUN_AUTOCONF