package/sdl_image: fix WebP dynamically loaded on host build
authorPaul Cercueil <paul@crapouillou.net>
Sun, 12 Jul 2020 19:57:11 +0000 (21:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jul 2020 20:57:37 +0000 (22:57 +0200)
Just like with libjpeg and libpng, we don't want libwebp to be
dynamically loaded by SDL_image at runtime.

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sdl_image/sdl_image.mk

index ee0712cc2747f348072e56489c47de67cbe8338d..46a28799cfe86fa1ae4cd093b6fb025f8591cb51 100644 (file)
@@ -43,7 +43,8 @@ HOST_SDL_IMAGE_CONF_OPTS = \
        --disable-static \
        --disable-jpg-shared \
        --disable-png-shared \
-       --disable-tif-shared
+       --disable-tif-shared \
+       --disable-webp-shared
 
 HOST_SDL_IMAGE_DEPENDENCIES = host-libjpeg host-libpng host-sdl