slang: fix linking issue
authorRomain Naour <romain.naour@openwide.fr>
Thu, 27 Mar 2014 23:06:32 +0000 (00:06 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 28 Mar 2014 08:54:41 +0000 (09:54 +0100)
The installation location of the slang library
does not take into account the DESTDIR directory.
So SLANG_INST_LIB is initialized with -L/usr/lib/
and slang may be linked with host's libdl.so (if any)
Therefore, we have to pass correct installation paths.

Fixes:
http://autobuild.buildroot.net/results/df4/df435d9cebbdc84b3581ba258b618123570dde8b/

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/slang/slang.mk

index d519eca4b55f074229f591c84be0826ef325cc44..c6f0383833b62c9ad693050dc7bed39be1b3ce5c 100644 (file)
@@ -13,4 +13,21 @@ SLANG_LICENSE_FILES = COPYING
 SLANG_INSTALL_STAGING = YES
 SLANG_MAKE = $(MAKE1)
 
+# The installation location of the slang library
+# does not take into account the DESTDIR directory.
+# So SLANG_INST_LIB is initialized with -L/usr/lib/
+# and slang may be linked with host's libdl.so (if any)
+# Therefore, we have to pass correct installation paths.
+SLANG_INSTALL_STAGING_OPT = \
+       prefix=$(STAGING_DIR)/usr \
+       exec_prefix=$(STAGING_DIR)/usr \
+       DESTDIR=$(STAGING_DIR) \
+       install
+
+SLANG_INSTALL_TARGET_OPT = \
+       prefix=$(STAGING_DIR)/usr \
+       exec_prefix=$(STAGING_DIR)/usr \
+       DESTDIR=$(TARGET_DIR) \
+       install
+
 $(eval $(autotools-package))