e2fsprogs: bump to version 1.43
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 18 May 2016 19:08:23 +0000 (16:08 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 23 May 2016 11:56:55 +0000 (13:56 +0200)
Add new fuse2fs option and disable it for host-e2fsprogs to avoid
carrying over unused/unnecessary distro/host dependencies.

Move E2FSPROGS_DEPENDENCIES to the top to avoid nasty mistakes (like
resetting a previous conditional addition).

License file renamed from COPYING to NOTICE.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/e2fsprogs/Config.in
package/e2fsprogs/e2fsprogs.hash
package/e2fsprogs/e2fsprogs.mk

index e540337d7f2589b2c2a656a5adfdc64096aae9da..cf43dbcc696803ff004767e8d4371a98b3f8c668 100644 (file)
@@ -62,6 +62,15 @@ config BR2_PACKAGE_E2FSPROGS_FSCK
        bool "fsck"
        default y
 
+config BR2_PACKAGE_E2FSPROGS_FUSE2FS
+       bool "fuse2fs"
+       depends on !BR2_STATIC_LIBS # libfuse
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libfuse
+       select BR2_PACKAGE_LIBFUSE
+
+comment "fuse2fs needs a toolchain w/ threads, dynamic library"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
+
 config BR2_PACKAGE_E2FSPROGS_LOGSAVE
        bool "logsave"
        default y
index 1585037750aa7199ff00b34fad1eb72a8b072d85..3cc90fddf870d9261f7c2a2d6575e23b9177db1c 100644 (file)
@@ -1,2 +1,2 @@
-# From https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v1.42.13/sha256sums.asc
-sha256 e16474b5a3a30f9197160c4b91bd48d5a463583049c0fcc405b6f0f7075aa0c7 e2fsprogs-1.42.13.tar.xz
+# From https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v1.43/sha256sums.asc
+sha256 d027eec0282e169eb55229beefca258c425c9d96f65292e2c004012d5353cd38        e2fsprogs-1.43.tar.xz
index 3de4cd48727f213c2f26d490d16373d61e833c2e..c1cbf715a47f6446a42d9e6c62c24e2df6935f6f 100644 (file)
@@ -4,17 +4,19 @@
 #
 ################################################################################
 
-E2FSPROGS_VERSION = 1.42.13
+E2FSPROGS_VERSION = 1.43
 E2FSPROGS_SOURCE = e2fsprogs-$(E2FSPROGS_VERSION).tar.xz
 E2FSPROGS_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/people/tytso/e2fsprogs/v$(E2FSPROGS_VERSION)
 E2FSPROGS_LICENSE = GPLv2, libuuid BSD-3c, libss and libet MIT-like with advertising clause
-E2FSPROGS_LICENSE_FILES = COPYING lib/uuid/COPYING lib/ss/mit-sipb-copyright.h lib/et/internal.h
+E2FSPROGS_LICENSE_FILES = NOTICE lib/uuid/COPYING lib/ss/mit-sipb-copyright.h lib/et/internal.h
 E2FSPROGS_INSTALL_STAGING = YES
 E2FSPROGS_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install-libs
+E2FSPROGS_DEPENDENCIES = host-pkgconf util-linux
 
 # e4defrag doesn't build on older systems like RHEL5.x, and we don't
 # need it on the host anyway.
-HOST_E2FSPROGS_CONF_OPTS += --disable-defrag
+# Disable fuse2fs as well to avoid carrying over deps, and it's unused
+HOST_E2FSPROGS_CONF_OPTS += --disable-defrag --disable-fuse2fs
 
 E2FSPROGS_CONF_OPTS = \
        $(if $(BR2_STATIC_LIBS),,--enable-elf-shlibs) \
@@ -30,6 +32,13 @@ E2FSPROGS_CONF_OPTS = \
        --disable-testio-debug \
        --disable-rpath
 
+ifeq ($(BR2_PACKAGE_E2FSPROGS_FUSE2FS),y)
+E2FSPROGS_CONF_OPTS += --enable-fuse2fs
+E2FSPROGS_DEPENDENCIES += libfuse
+else
+E2FSPROGS_CONF_OPTS += --disable-fuse2fs
+endif
+
 ifeq ($(BR2_nios2),y)
 E2FSPROGS_CONF_ENV += ac_cv_func_fallocate=no
 endif
@@ -40,8 +49,6 @@ ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
 E2FSPROGS_CONF_ENV += LIBS=-lintl
 endif
 
-E2FSPROGS_DEPENDENCIES = host-pkgconf util-linux
-
 E2FSPROGS_MAKE_OPTS = \
        LDCONFIG=true