make: select gettext and libintl if locale is enabled
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Wed, 5 Nov 2008 08:09:30 +0000 (08:09 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Wed, 5 Nov 2008 08:09:30 +0000 (08:09 -0000)
This patch makes sure gettext and libintl are selected if locale support is
enabled. Gettext must also be compiled before make so appropriate headers are
available to make.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/make/Config.in
package/make/make.mk

index 7dc19c52e8a3cb771b845d769af78287b1635867..52640058eaaf638cd9ceeb4da153713f483f2f7d 100644 (file)
@@ -1,5 +1,7 @@
 config BR2_PACKAGE_MAKE
        bool "make"
+       select BR2_PACKAGE_GETTEXT if BR2_ENABLE_LOCALE
+       select BR2_PACKAGE_LIBINTL if BR2_ENABLE_LOCALE
        help
          A tool which controls the generation of executables and other
          non-source files of a program from the program's source files.
index 4f11f504d25e83630c62083994f206257e02443d..4cc5e1597ae32c49d143881436574752f28696a4 100644 (file)
@@ -71,5 +71,5 @@ make-dirclean:
 #
 #############################################################
 ifeq ($(strip $(BR2_PACKAGE_MAKE)),y)
-TARGETS+=make
+TARGETS+=$(if $(BR2_PACKAGE_GETTEXT),gettext) make
 endif