package/grpc: drop host gcc 4.8 workaround
authorMichael Nosthoff <buildroot@heine.tech>
Mon, 18 Jan 2021 09:46:33 +0000 (10:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 18 Jan 2021 21:22:44 +0000 (22:22 +0100)
Due to libabseil dependencies the host gcc is at least 4.9.
So the fix for host gcc 4.8 is no longer needed.

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/grpc/grpc.mk

index 8585b6bdc3905b58b10ee5b2ecef470023ce31f9..f7ddffd386d0f87e595b213a74b4eec43d6c537c 100644 (file)
@@ -72,13 +72,5 @@ HOST_GRPC_CONF_OPTS = \
        -DgRPC_SSL_PROVIDER=package \
        -DgRPC_ZLIB_PROVIDER=package
 
-# With gcc 4.8 (at least on ubuntu) there is a bug in LTO which breaks
-# the linkage of the grpc_cpp_plugin with libprotobuf and pthread. This
-# additional flag fixes this.
-ifeq ($(BR2_HOST_GCC_AT_LEAST_4_9),)
-HOST_GRPC_CONF_OPTS += \
-       -DCMAKE_EXE_LINKER_FLAGS="$(HOST_LDFLAGS) -Wl,--no-as-needed"
-endif
-
 $(eval $(cmake-package))
 $(eval $(host-cmake-package))