package./systemd: disable utmp
authorNorbert Lange <nolange79@gmail.com>
Sat, 18 Jul 2020 20:37:02 +0000 (22:37 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 18 Jul 2020 20:43:25 +0000 (22:43 +0200)
From wikipedia:

    utmp maintains a full accounting of the current status of the
    system, system boot time (used by uptime), recording user
    logins at which terminals, logouts, system events etc.

This is seldom use, if at all, on an embedded device, and may expose
users' behaviour to others (by observing who logs in from where, for
example).

Forcibly disable support for utmp.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
[yann.morin.1998@free.fr: split off to its own patch]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/systemd/systemd.mk

index 733d170193babd8d12f773475521fbeb2cb536c8..a9a750a55fced0a5cf12e2e8131c2d1ca748828d 100644 (file)
@@ -24,6 +24,7 @@ SYSTEMD_CONF_OPTS += \
        -Drootlibdir='/usr/lib' \
        -Dsysvinit-path= \
        -Dsysvrcnd-path= \
+       -Dutmp=false \
        -Dblkid=true \
        -Dman=false \
        -Dima=false \