ffmpeg: fix ARM condition for --{enable, disable}-vfp
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Oct 2014 20:26:50 +0000 (22:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Oct 2014 10:35:17 +0000 (12:35 +0200)
As noted by Arnout, not all ARMv6 have the VFP FPU, therefore instead
of using a condition on ARMv6 or ARMv7-A, this commit changes to use a
condition on BR2_ARM_CPU_HAS_VFPV2.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/ffmpeg/ffmpeg.mk

index 349bac9bf3a798b97a7e765edf0097f91bf2cbf0..0990f1878a9ec881b752ce3dce9c4d2d1130b7b7 100644 (file)
@@ -285,7 +285,7 @@ FFMPEG_CONF_OPTS += --enable-armv6
 else
 FFMPEG_CONF_OPTS += --disable-armv6 --disable-armv6t2
 endif
-ifeq ($(BR2_ARM_CPU_ARMV6)$(BR2_ARM_CPU_ARMV7A),y)
+ifeq ($(BR2_ARM_CPU_HAS_VFPV2),y)
 FFMPEG_CONF_OPTS += --enable-vfp
 else
 FFMPEG_CONF_OPTS += --disable-vfp