Revert "package/cwiid: add optional dependency to bluez5_utils"
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Mar 2017 21:38:37 +0000 (22:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Mar 2017 21:38:37 +0000 (22:38 +0100)
This reverts commit d4c4c259d25a8f2c5c2e2a5736609ba285fdd018. It was
mistakenly committed and pushed: it causes Kconfig circular
dependencies, so it cannot be applied as-is.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cwiid/Config.in
package/cwiid/cwiid.mk

index 69e54f5b79d683a08aabf2e2497f3941c70248b5..03b7dbbcdb8024c2223e03009acc8f012ce09203 100644 (file)
@@ -4,7 +4,7 @@ config BR2_PACKAGE_CWIID
        depends on BR2_USE_WCHAR # bluez_utils -> libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # bluez_utils -> dbus, alsa-lib, libglib2
        depends on BR2_USE_MMU # bluez_utils -> dbus, libglib2
-       select BR2_PACKAGE_BLUEZ_UTILS if !BR2_PACKAGE_BLUEZ5_UTILS
+       select BR2_PACKAGE_BLUEZ_UTILS
        help
          A collection of Linux tools written in C for interfacing to the
          Nintendo Wiimote.
index 5bccebe872769b69cb65db4a1be091c2505702d0..36450c17e421cefa0b80dbd4ec2fd4310a9254db 100644 (file)
@@ -12,19 +12,13 @@ CWIID_LICENSE_FILES = COPYING
 CWIID_AUTORECONF = YES
 CWIID_INSTALL_STAGING = YES
 
-CWIID_DEPENDENCIES = host-pkgconf host-bison host-flex
+CWIID_DEPENDENCIES = host-pkgconf host-bison host-flex bluez_utils
 
 # Disable python support. This disables the 2 following things:
 #   - wminput Python plugin support
 #   - cwiid Python module
 CWIID_CONF_OPTS = --without-python --disable-ldconfig
 
-ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
-CWIID_DEPENDENCIES += bluez5_utils
-else
-CWIID_DEPENDENCIES += bluez_utils
-endif
-
 ifeq ($(BR2_PACKAGE_CWIID_WMGUI),y)
 CWIID_DEPENDENCIES += libgtk2 libglib2
 CWIID_CONF_OPTS += --enable-wmgui