projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
80997ac
)
package/ruby: links with atomic if needed
author
Fabrice Fontaine
<fontaine.fabrice@gmail.com>
Mon, 10 May 2021 20:37:10 +0000
(22:37 +0200)
committer
Peter Korsgaard
<peter@korsgaard.com>
Tue, 11 May 2021 07:50:09 +0000
(09:50 +0200)
Build fails since bump to version 3.0.0 in commit
af5226f2fd1292a26f2dfda32f41cbbad7aa4cc
because ruby needs atomic
operation support since
https://github.com/ruby/ruby/commit/
6ed6b85ece8733518a7da0c3ec714f20d1102bf5
Fixes:
- http://autobuild.buildroot.org/results/
84ee5f4688be994a5440c3a61bddabee72ca3b3c
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ruby/ruby.mk
patch
|
blob
|
history
diff --git
a/package/ruby/ruby.mk
b/package/ruby/ruby.mk
index fded7acebc7f4b1c2877c122e64f3618923f4c00..a71ca3a8a2419bb447f536a8ee809831e2758ee2 100644
(file)
--- a/
package/ruby/ruby.mk
+++ b/
package/ruby/ruby.mk
@@
-23,6
+23,10
@@
RUBY_CPE_ID_VENDOR = ruby-lang
# 0001-fix-default-coroutine-selection.patch
RUBY_AUTORECONF = YES
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+RUBY_CONF_ENV += LIBS=-latomic
+endif
+
ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
# On uClibc, finite, isinf and isnan are not directly implemented as
# functions. Instead math.h #define's these to __finite, __isinf and