package: add a PRE_PATCH_HOOKS hook point
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 19 Sep 2011 20:10:52 +0000 (22:10 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 20 Sep 2011 20:18:14 +0000 (22:18 +0200)
This will be useful to integrate Xenomai and RTAI into Buildroot, so
that they can patch the kernel before the normal patching process
starts.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.package.in

index 66be0a2377641cf479b71381566d67269f120375..e2d0e28cef830f605a4636559efdac45d13003f9 100644 (file)
@@ -259,6 +259,7 @@ $(BUILD_DIR)/%/.stamp_extracted:
 $(BUILD_DIR)/%/.stamp_patched: NAMEVER = $(RAWNAME)-$($(PKG)_VERSION)
 $(BUILD_DIR)/%/.stamp_patched:
        @$(call MESSAGE,"Patching $($(PKG)_DIR_PREFIX)/$(RAWNAME)")
+       $(foreach hook,$($(PKG)_PRE_PATCH_HOOKS),$(call $(hook))$(sep))
        $(if $($(PKG)_PATCH),support/scripts/apply-patches.sh $(@D) $(DL_DIR) $($(PKG)_PATCH))
        $(Q)( \
        if test -d $($(PKG)_DIR_PREFIX)/$(RAWNAME); then \
@@ -443,6 +444,7 @@ $(2)_EXTRACT_CMDS ?= \
 # post-steps hooks
 $(2)_POST_DOWNLOAD_HOOKS        ?=
 $(2)_POST_EXTRACT_HOOKS         ?=
+$(2)_PRE_PATCH_HOOKS            ?=
 $(2)_POST_PATCH_HOOKS           ?=
 $(2)_PRE_CONFIGURE_HOOKS        ?=
 $(2)_POST_CONFIGURE_HOOKS       ?=