toolchain: copy_toolchain_lib_root: rename LIBSPATH to LIBPATHS
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Wed, 3 Feb 2016 21:45:28 +0000 (22:45 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Feb 2016 22:46:00 +0000 (23:46 +0100)
LIBSPATH is populated based on a find with a pattern that can look like:
    libfoo*.so
and thus the output of the find will contain all file paths that match this
pattern.

Unfortunately, the name LIBSPATH suggests that only one entry is returned,
rather than possibly multiple.

As this code is quite complex, use the more accurate name LIBPATHS iso
LIBSPATH.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/helpers.mk

index 02cc0bb174701181480e43706410b11384ab1f15..ee878e89a16ed8fb65a29345373446aef7078f8b 100644 (file)
@@ -55,13 +55,13 @@ copy_toolchain_lib_root = \
                $${ARCH_SYSROOT_DIR}/$${ARCH_LIB_DIR} \
                $${ARCH_SYSROOT_DIR}/usr/$${ARCH_LIB_DIR} \
                $${SUPPORT_LIB_DIR} ; do \
-               LIBSPATH=`find $${dir} -maxdepth 1 -name "$${LIB}" 2>/dev/null` ; \
-               if test -n "$${LIBSPATH}" ; then \
+               LIBPATHS=`find $${dir} -maxdepth 1 -name "$${LIB}" 2>/dev/null` ; \
+               if test -n "$${LIBPATHS}" ; then \
                        break ; \
                fi \
        done ; \
        mkdir -p $(TARGET_DIR)/$${DESTDIR}; \
-       for LIBPATH in $${LIBSPATH} ; do \
+       for LIBPATH in $${LIBPATHS} ; do \
                while true ; do \
                        LIBNAME=`basename $${LIBPATH}`; \
                        LIBDIR=`dirname $${LIBPATH}` ; \