package/sysklogd: fix installation path of the daemons
authorCarlos Santos <unixmania@gmail.com>
Sun, 15 Mar 2020 02:27:06 +0000 (23:27 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Mar 2020 21:55:47 +0000 (22:55 +0100)
Use "--exec-prefix=/" to install syslogd and klogd at /sbin, as required
by the init scripts. This also ensures that the BusyBox counterparts are
not installed.

Update the systemd unit files, accordingly.

Signed-off-by: Carlos Santos <unixmania@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sysklogd/klogd.service
package/sysklogd/sysklogd.mk
package/sysklogd/syslogd.service

index c66795b449ebcb6b0a44da6165e2f38ab7778c7f..b5dbb93d7d4e316f5adf2b90f7c1ea00ed10d20a 100644 (file)
@@ -2,7 +2,7 @@
 Description=Kernel Log Daemon
 
 [Service]
-ExecStart=/usr/sbin/klogd -n
+ExecStart=/sbin/klogd -n
 StandardOutput=null
 Restart=on-failure
 
index 1bd1ec51b51dbc8ef79f659a9681ad40a078ff0f..7a25d0eb6f49556ba0d793fafc6074fb627073f2 100644 (file)
@@ -10,6 +10,7 @@ SYSKLOGD_LICENSE = GPL-2.0+
 SYSKLOGD_LICENSE_FILES = COPYING
 # From git
 SYSKLOGD_AUTORECONF = YES
+SYSKLOGD_CONF_OPTS = --exec-prefix=/
 
 define SYSKLOGD_INSTALL_SAMPLE_CONFIG
        $(INSTALL) -D -m 0644 package/sysklogd/syslog.conf \
index 70e4cff27e9c3f8af8481a7fc54074f6a12655c5..adaac679f28fed308d133657162a82f75e7abdaa 100644 (file)
@@ -4,7 +4,7 @@ Requires=syslog.socket
 Wants=klogd.service
 
 [Service]
-ExecStart=/usr/sbin/syslogd -m 0 -n
+ExecStart=/sbin/syslogd -m 0 -n
 StandardOutput=null
 Restart=on-failure