iprutils: rename patches to follow the new name convention
authorRomain Naour <romain.naour@openwide.fr>
Fri, 12 Dec 2014 23:30:32 +0000 (00:30 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 14 Dec 2014 18:55:17 +0000 (19:55 +0100)
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/iprutils/0001-Don-t-use-gettext.patch [new file with mode: 0644]
package/iprutils/0002-Allow-CFLAGS-to-be-extended-from-the-enviro.patch [new file with mode: 0644]
package/iprutils/0003-Fix-static-build-by-passing-the-libraries-i.patch [new file with mode: 0644]
package/iprutils/iprutils-0001-Don-t-use-gettext.patch [deleted file]
package/iprutils/iprutils-0002-Allow-CFLAGS-to-be-extended-from-the-enviro.patch [deleted file]
package/iprutils/iprutils-0003-Fix-static-build-by-passing-the-libraries-i.patch [deleted file]

diff --git a/package/iprutils/0001-Don-t-use-gettext.patch b/package/iprutils/0001-Don-t-use-gettext.patch
new file mode 100644 (file)
index 0000000..a80cc87
--- /dev/null
@@ -0,0 +1,32 @@
+From 34fb0785f1d66ba1f79b470223426031f6258782 Mon Sep 17 00:00:00 2001
+From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+Date: Wed, 17 Sep 2014 17:48:54 +0100
+Subject: [PATCH 1/3] iprutils: Don't use gettext
+
+... since we don't have any translation.
+
+Based on the former patch by Jeremy Kerr.
+
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+---
+ iprconfig.h |    4 +---
+ 1 files changed, 1 insertions(+), 3 deletions(-)
+
+diff --git a/iprconfig.h b/iprconfig.h
+index cad591a..4a1fa0d 100644
+--- a/iprconfig.h
++++ b/iprconfig.h
+@@ -11,9 +11,7 @@
+  *
+  **/
+-#include <libintl.h>
+-
+-#define _(string) gettext(string)
++#define _(string) (string)
+ #define __(string) (string)
+ #define EXIT_FLAG             0x8000  /* stops at given screen on exit call */
+ #define CANCEL_FLAG           0x4000  /* stops at given screen on quit call */
+-- 
+1.7.1
+
diff --git a/package/iprutils/0002-Allow-CFLAGS-to-be-extended-from-the-enviro.patch b/package/iprutils/0002-Allow-CFLAGS-to-be-extended-from-the-enviro.patch
new file mode 100644 (file)
index 0000000..dbfa008
--- /dev/null
@@ -0,0 +1,31 @@
+From 9a46afebdc63ba67cd95748f898969d6c622a129 Mon Sep 17 00:00:00 2001
+From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+Date: Wed, 17 Sep 2014 18:08:31 +0100
+Subject: [PATCH 1/2] iprutils: Allow CFLAGS to be extended from the environment
+
+We also remove -g, since we don't necessarily want to build with
+debugging symbols. Buildroot will add -g if needed.
+
+Based on the former patch by Thomas Petazzoni.
+
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+---
+ Makefile |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index c4e2427..66c4942 100644
+--- a/Makefile
++++ b/Makefile
+@@ -9,7 +9,7 @@ CC = gcc
+ include version.mk
+-CFLAGS += -g -Wall $(IPR_DEFINES)
++override CFLAGS += -Wall $(IPR_DEFINES)
+ UTILS_VER = $(IPR_MAJOR_RELEASE).$(IPR_MINOR_RELEASE).$(IPR_FIX_LEVEL)
+ TAR = cd .. && tar -zcpf iprutils-$(UTILS_VER)-src.tgz --exclude .git --exclude CVS --exclude applied-patches --exclude series --exclude txt --exclude pc --exclude patches --exclude debug --exclude *~* iprutils
+-- 
+1.7.1
+
diff --git a/package/iprutils/0003-Fix-static-build-by-passing-the-libraries-i.patch b/package/iprutils/0003-Fix-static-build-by-passing-the-libraries-i.patch
new file mode 100644 (file)
index 0000000..e176ab6
--- /dev/null
@@ -0,0 +1,20 @@
+iprutils: Fix static build by passing the libraries in the right order
+
+This mistake was causing failures like this one:
+
+m_post.c:(.text+0x60): undefined reference to `wattr_on'
+
+http://autobuild.buildroot.net/results/500/5004e7b230635e0605acdd17d2b7d2d01fc5075c/build-end.log
+
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
+--- iprutils-2.4.2/Makefile.orig       2014-09-17 18:14:52.435367860 +0100
++++ iprutils-2.4.2/Makefile    2014-09-17 18:15:09.367652526 +0100
+@@ -16,7 +16,7 @@ TAR = cd .. && tar -zcpf iprutils-$(UTIL
+ all: iprconfig iprupdate iprdump iprinit iprdbg docs 
+ iprconfig: iprconfig.c iprlib.o iprconfig.h
+-      $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprconfig iprconfig.c iprlib.o $(LDFLAGS) -lform -lpanel -lncurses -lmenu
++      $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprconfig iprconfig.c iprlib.o $(LDFLAGS) -lform -lpanel -lmenu -lncurses
+ iprupdate: iprupdate.c iprlib.o
+       $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprupdate iprlib.o iprupdate.c $(LDFLAGS)
diff --git a/package/iprutils/iprutils-0001-Don-t-use-gettext.patch b/package/iprutils/iprutils-0001-Don-t-use-gettext.patch
deleted file mode 100644 (file)
index a80cc87..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 34fb0785f1d66ba1f79b470223426031f6258782 Mon Sep 17 00:00:00 2001
-From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
-Date: Wed, 17 Sep 2014 17:48:54 +0100
-Subject: [PATCH 1/3] iprutils: Don't use gettext
-
-... since we don't have any translation.
-
-Based on the former patch by Jeremy Kerr.
-
-Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
----
- iprconfig.h |    4 +---
- 1 files changed, 1 insertions(+), 3 deletions(-)
-
-diff --git a/iprconfig.h b/iprconfig.h
-index cad591a..4a1fa0d 100644
---- a/iprconfig.h
-+++ b/iprconfig.h
-@@ -11,9 +11,7 @@
-  *
-  **/
--#include <libintl.h>
--
--#define _(string) gettext(string)
-+#define _(string) (string)
- #define __(string) (string)
- #define EXIT_FLAG             0x8000  /* stops at given screen on exit call */
- #define CANCEL_FLAG           0x4000  /* stops at given screen on quit call */
--- 
-1.7.1
-
diff --git a/package/iprutils/iprutils-0002-Allow-CFLAGS-to-be-extended-from-the-enviro.patch b/package/iprutils/iprutils-0002-Allow-CFLAGS-to-be-extended-from-the-enviro.patch
deleted file mode 100644 (file)
index dbfa008..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 9a46afebdc63ba67cd95748f898969d6c622a129 Mon Sep 17 00:00:00 2001
-From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
-Date: Wed, 17 Sep 2014 18:08:31 +0100
-Subject: [PATCH 1/2] iprutils: Allow CFLAGS to be extended from the environment
-
-We also remove -g, since we don't necessarily want to build with
-debugging symbols. Buildroot will add -g if needed.
-
-Based on the former patch by Thomas Petazzoni.
-
-Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
----
- Makefile |    2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index c4e2427..66c4942 100644
---- a/Makefile
-+++ b/Makefile
-@@ -9,7 +9,7 @@ CC = gcc
- include version.mk
--CFLAGS += -g -Wall $(IPR_DEFINES)
-+override CFLAGS += -Wall $(IPR_DEFINES)
- UTILS_VER = $(IPR_MAJOR_RELEASE).$(IPR_MINOR_RELEASE).$(IPR_FIX_LEVEL)
- TAR = cd .. && tar -zcpf iprutils-$(UTILS_VER)-src.tgz --exclude .git --exclude CVS --exclude applied-patches --exclude series --exclude txt --exclude pc --exclude patches --exclude debug --exclude *~* iprutils
--- 
-1.7.1
-
diff --git a/package/iprutils/iprutils-0003-Fix-static-build-by-passing-the-libraries-i.patch b/package/iprutils/iprutils-0003-Fix-static-build-by-passing-the-libraries-i.patch
deleted file mode 100644 (file)
index e176ab6..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-iprutils: Fix static build by passing the libraries in the right order
-
-This mistake was causing failures like this one:
-
-m_post.c:(.text+0x60): undefined reference to `wattr_on'
-
-http://autobuild.buildroot.net/results/500/5004e7b230635e0605acdd17d2b7d2d01fc5075c/build-end.log
-
-Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---- iprutils-2.4.2/Makefile.orig       2014-09-17 18:14:52.435367860 +0100
-+++ iprutils-2.4.2/Makefile    2014-09-17 18:15:09.367652526 +0100
-@@ -16,7 +16,7 @@ TAR = cd .. && tar -zcpf iprutils-$(UTIL
- all: iprconfig iprupdate iprdump iprinit iprdbg docs 
- iprconfig: iprconfig.c iprlib.o iprconfig.h
--      $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprconfig iprconfig.c iprlib.o $(LDFLAGS) -lform -lpanel -lncurses -lmenu
-+      $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprconfig iprconfig.c iprlib.o $(LDFLAGS) -lform -lpanel -lmenu -lncurses
- iprupdate: iprupdate.c iprlib.o
-       $(CC) $(CFLAGS) $(INCLUDEDIR) -o iprupdate iprlib.o iprupdate.c $(LDFLAGS)