package/libasplib: fix build error on m68k
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 1 Jan 2017 12:02:44 +0000 (13:02 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Jan 2017 03:44:42 +0000 (16:44 +1300)
Patch written by Waldemar Brodkorb:
http://lists.busybox.net/pipermail/buildroot/2016-November/177726.html

This patch however did not work: "Unfortunately libasplib cmake
infrastructure ignores my CMAKE_CXX_FLAGS."

To make this patch work libasplib needed to be bumped because the cmake
infrastructure was updated back in August 2016 which fixed the problem:
https://github.com/AchimTuran/asplib/commit/6326d1f5e8dad9fd9947b7f4688ddddda91e9e9e

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libasplib/libasplib.mk

index 038fc389e3b192169d63461c798d66746d595b22..b3b1fdb30f1a0b112a841beec75df944e1febe3c 100644 (file)
@@ -18,4 +18,11 @@ LIBASPLIB_CONF_OPTS = \
        -DBUILD_SIGNALS=ON \
        -DBUILD_TIMER=ON
 
+# Internal error, aborting at dw2gencfi.c:214 in emit_expr_encoded
+ifeq ($(BR2_m68k_cf),y)
+LIBASPLIB_CXXFLAGS += -fno-dwarf2-cfi-asm
+endif
+
+LIBASPLIB_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) $(LIBASPLIB_CXXFLAGS)"
+
 $(eval $(cmake-package))