Remove cc-option: not used anywhere
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Apr 2012 14:45:14 +0000 (16:45 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 19 Apr 2012 13:53:53 +0000 (15:53 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 3a09417ad41ff6a83768bfd001108e8e64ade899..55d552b7bf9b778648349d382092b50603988ac6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -178,13 +178,6 @@ BUILD_DIR:=$(BASE_DIR)/build
 
 ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
-# cc-option
-# Usage: cflags-y+=$(call cc-option, -march=winchip-c6, -march=i586)
-# sets -march=winchip-c6 if supported else falls back to -march=i586
-# without checking the latter.
-cc-option=$(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /dev/null \
-       > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ;)
-
 #############################################################
 #
 # Hide troublesome environment variables from sub processes