wayland: remove Blackfin patch
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 5 Apr 2018 19:50:36 +0000 (21:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Apr 2018 20:05:45 +0000 (22:05 +0200)
And renumber remaining patch.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wayland/0001-Support-architectures-with-non-empty-__USER_LABEL_PR.patch [deleted file]
package/wayland/0001-configure-add-option-to-disable-tests.patch [new file with mode: 0644]
package/wayland/0002-configure-add-option-to-disable-tests.patch [deleted file]

diff --git a/package/wayland/0001-Support-architectures-with-non-empty-__USER_LABEL_PR.patch b/package/wayland/0001-Support-architectures-with-non-empty-__USER_LABEL_PR.patch
deleted file mode 100644 (file)
index abefcff..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-From 0a337328411d5b3f37b169a83b6fee3f1726130f Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Thu, 26 May 2016 15:57:33 +0200
-Subject: [PATCH] Support architectures with non-empty __USER_LABEL_PREFIX__
-
-On some architectures (like Blackfin), a C symbol does not directly
-match with assembly symbols. The C symbol references are in fact all
-prefixed by a so-called "user label prefix". So when a symbol defined
-in an assembly file needs to be referenced from C, this symbol should
-be prefixed by the "user label prefix".
-
-This commit updates dtddata.S to take into account
-__USER_LABEL_PREFIX__ when it exists.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- src/dtddata.S | 19 +++++++++++++------
- 1 file changed, 13 insertions(+), 6 deletions(-)
-
-diff --git a/src/dtddata.S b/src/dtddata.S
-index ce51133..ad2a4db 100644
---- a/src/dtddata.S
-+++ b/src/dtddata.S
-@@ -30,17 +30,24 @@
- /* from: http://www.linuxjournal.com/content/embedding-file-executable-aka-hello-world-version-5967#comment-348129 */
-+#ifdef __USER_LABEL_PREFIX__
-+#define CONCAT1(a, b) CONCAT2(a, b)
-+#define CONCAT2(a, b) a ## b
-+#define SYM(x) CONCAT1 (__USER_LABEL_PREFIX__, x)
-+#else
-+#endif
-+
- .macro binfile name file
-       .p2align 2
--      .globl \name\()_begin
--\name\()_begin:
-+      .globl SYM(\name\()_begin)
-+SYM(\name\()_begin):
-       .incbin "\file"
--\name\()_end:
-+SYM(\name\()_end):
-       .byte 0
-       .p2align 2
--      .globl \name\()_len
--\name\()_len:
--      .int (\name\()_end - \name\()_begin)
-+      .globl SYM(\name\()_len)
-+SYM(\name\()_len):
-+      .int (SYM(\name\()_end) - SYM(\name\()_begin))
- .endm
- .section .rodata
--- 
-2.7.4
-
diff --git a/package/wayland/0001-configure-add-option-to-disable-tests.patch b/package/wayland/0001-configure-add-option-to-disable-tests.patch
new file mode 100644 (file)
index 0000000..8c67d9a
--- /dev/null
@@ -0,0 +1,68 @@
+From 33b025e04bf3fa94b74ea3325b3fd7c3f546bcb1 Mon Sep 17 00:00:00 2001
+From: "Yann E. MORIN" <yann.morin.1998@free.fr>
+Date: Sun, 5 Mar 2017 10:06:02 +0100
+Subject: [PATCH] configure: add option to disable tests
+
+When building for a product, tests are not needed.
+
+Besides, one test requires a C++ compiler, which is not always
+available.
+
+So, add an option to configure to disable building tests altogether.
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+---
+Patch submitted upstream:
+https://lists.freedesktop.org/archives/wayland-devel/2017-March/033359.html
+---
+ Makefile.am  | 3 ++-
+ configure.ac | 8 ++++++++
+ 2 files changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index d0c8bd3..9c2541d 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -143,7 +143,7 @@ libwayland_cursor_la_CFLAGS =                      \
+       -I$(top_srcdir)/src                     \
+       -DICONDIR=\"$(ICONDIR)\"
+-
++if ENABLE_TESTS
+ built_test_programs =                         \
+       array-test                              \
+       client-test                             \
+@@ -258,6 +258,7 @@ os_wrappers_test_LDADD = libtest-runner.la
+ exec_fd_leak_checker_SOURCES = tests/exec-fd-leak-checker.c
+ exec_fd_leak_checker_LDADD = libtest-runner.la
++endif
+ EXTRA_DIST += tests/scanner-test.sh                   \
+       tests/data/example.xml                          \
+diff --git a/configure.ac b/configure.ac
+index b583bef..96a5575 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -87,10 +87,18 @@ AC_ARG_ENABLE([dtd-validation],
+             [],
+             [enable_dtd_validation=yes])
++AC_ARG_ENABLE([tests],
++            [AC_HELP_STRING([--disable-tests],
++                            [Disable compilation of test programs])],
++            [],
++            [enable_tests=yes])
++
+ AM_CONDITIONAL(USE_HOST_SCANNER, test "x$with_host_scanner" = xyes)
+ AM_CONDITIONAL(ENABLE_LIBRARIES, test "x$enable_libraries" = xyes)
++AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "yes")
++
+ AC_ARG_WITH(icondir, [  --with-icondir=<dir>    Look for cursor icons here],
+                    [  ICONDIR=$withval],
+                    [  ICONDIR=${datadir}/icons])
+-- 
+2.7.4
+
diff --git a/package/wayland/0002-configure-add-option-to-disable-tests.patch b/package/wayland/0002-configure-add-option-to-disable-tests.patch
deleted file mode 100644 (file)
index 8c67d9a..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-From 33b025e04bf3fa94b74ea3325b3fd7c3f546bcb1 Mon Sep 17 00:00:00 2001
-From: "Yann E. MORIN" <yann.morin.1998@free.fr>
-Date: Sun, 5 Mar 2017 10:06:02 +0100
-Subject: [PATCH] configure: add option to disable tests
-
-When building for a product, tests are not needed.
-
-Besides, one test requires a C++ compiler, which is not always
-available.
-
-So, add an option to configure to disable building tests altogether.
-
-Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
----
-Patch submitted upstream:
-https://lists.freedesktop.org/archives/wayland-devel/2017-March/033359.html
----
- Makefile.am  | 3 ++-
- configure.ac | 8 ++++++++
- 2 files changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index d0c8bd3..9c2541d 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -143,7 +143,7 @@ libwayland_cursor_la_CFLAGS =                      \
-       -I$(top_srcdir)/src                     \
-       -DICONDIR=\"$(ICONDIR)\"
--
-+if ENABLE_TESTS
- built_test_programs =                         \
-       array-test                              \
-       client-test                             \
-@@ -258,6 +258,7 @@ os_wrappers_test_LDADD = libtest-runner.la
- exec_fd_leak_checker_SOURCES = tests/exec-fd-leak-checker.c
- exec_fd_leak_checker_LDADD = libtest-runner.la
-+endif
- EXTRA_DIST += tests/scanner-test.sh                   \
-       tests/data/example.xml                          \
-diff --git a/configure.ac b/configure.ac
-index b583bef..96a5575 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -87,10 +87,18 @@ AC_ARG_ENABLE([dtd-validation],
-             [],
-             [enable_dtd_validation=yes])
-+AC_ARG_ENABLE([tests],
-+            [AC_HELP_STRING([--disable-tests],
-+                            [Disable compilation of test programs])],
-+            [],
-+            [enable_tests=yes])
-+
- AM_CONDITIONAL(USE_HOST_SCANNER, test "x$with_host_scanner" = xyes)
- AM_CONDITIONAL(ENABLE_LIBRARIES, test "x$enable_libraries" = xyes)
-+AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "yes")
-+
- AC_ARG_WITH(icondir, [  --with-icondir=<dir>    Look for cursor icons here],
-                    [  ICONDIR=$withval],
-                    [  ICONDIR=${datadir}/icons])
--- 
-2.7.4
-