projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2440385
)
bash: fails in parallel build
author
Arnout Vandecappelle
<arnout@mind.be>
Wed, 28 Aug 2013 21:29:35 +0000
(23:29 +0200)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Wed, 28 Aug 2013 21:58:27 +0000
(23:58 +0200)
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bash/bash.mk
patch
|
blob
|
history
diff --git
a/package/bash/bash.mk
b/package/bash/bash.mk
index efd2334ad0e768929fb2dd279c43467997ee2ac9..0c8a954b20b1dd0e802720dc02c1762662ee0724 100644
(file)
--- a/
package/bash/bash.mk
+++ b/
package/bash/bash.mk
@@
-16,6
+16,10
@@
BASH_CONF_ENV += \
bash_cv_func_sigsetjmp=present \
bash_cv_printf_a_format=yes
+# Parallel build sometimes fails because some of the generator tools
+# are built twice (i.e. while executing).
+BASH_MAKE = $(MAKE1)
+
# The static build needs some trickery
ifeq ($(BR2_PREFER_STATIC_LIB),y)
BASH_CONF_OPT += --enable-static-link --without-bash-malloc