perl-http-entity-parser: new package
authorFrancois Perrad <fperrad@gmail.com>
Sat, 6 Oct 2018 16:55:20 +0000 (18:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 8 Oct 2018 14:22:33 +0000 (16:22 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/perl-http-entity-parser/Config.in [new file with mode: 0644]
package/perl-http-entity-parser/perl-http-entity-parser.hash [new file with mode: 0644]
package/perl-http-entity-parser/perl-http-entity-parser.mk [new file with mode: 0644]

index 309a9cfeccbc144111771cdb6aed88e745f537c3..a3f971aa5535894f0b1aa770a2595e0c8cb9ef0a 100644 (file)
@@ -707,6 +707,7 @@ menu "Perl libraries/modules"
        source "package/perl-http-cookies/Config.in"
        source "package/perl-http-daemon/Config.in"
        source "package/perl-http-date/Config.in"
+       source "package/perl-http-entity-parser/Config.in"
        source "package/perl-http-message/Config.in"
        source "package/perl-http-multipartparser/Config.in"
        source "package/perl-http-negotiate/Config.in"
diff --git a/package/perl-http-entity-parser/Config.in b/package/perl-http-entity-parser/Config.in
new file mode 100644 (file)
index 0000000..41883ac
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PERL_HTTP_ENTITY_PARSER
+       bool "perl-http-entity-parser"
+       select BR2_PACKAGE_PERL_HTTP_MULTIPARTPARSER
+       select BR2_PACKAGE_PERL_HASH_MULTIVALUE
+       select BR2_PACKAGE_PERL_JSON_MAYBEXS
+       select BR2_PACKAGE_PERL_STREAM_BUFFERED
+       select BR2_PACKAGE_PERL_WWW_FORM_URLENCODED
+       help
+         PSGI compliant HTTP Entity Parser
+
+         https://github.com/kazeburo/HTTP-Entity-Parser
diff --git a/package/perl-http-entity-parser/perl-http-entity-parser.hash b/package/perl-http-entity-parser/perl-http-entity-parser.hash
new file mode 100644 (file)
index 0000000..cb66574
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    50e8418bfe27ab26818ca6e264052c95 HTTP-Entity-Parser-0.21.tar.gz
+sha256 c14d3e42bdb0845eb412640ca5e396cbd52d3a9a616a5974a32a52cab487f8d8 HTTP-Entity-Parser-0.21.tar.gz
+
+# computed by scancpan
+sha256 79c2a066104e71602785fd815c5aea6f7db78c19451d68521380083f9c2a8805 LICENSE
diff --git a/package/perl-http-entity-parser/perl-http-entity-parser.mk b/package/perl-http-entity-parser/perl-http-entity-parser.mk
new file mode 100644 (file)
index 0000000..980ee92
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# perl-http-entity-parser
+#
+################################################################################
+
+PERL_HTTP_ENTITY_PARSER_VERSION = 0.21
+PERL_HTTP_ENTITY_PARSER_SOURCE = HTTP-Entity-Parser-$(PERL_HTTP_ENTITY_PARSER_VERSION).tar.gz
+PERL_HTTP_ENTITY_PARSER_SITE = $(BR2_CPAN_MIRROR)/authors/id/K/KA/KAZEBURO
+PERL_HTTP_ENTITY_PARSER_DEPENDENCIES = \
+       host-perl-module-build-tiny \
+       perl-http-multipartparser \
+       perl-hash-multivalue \
+       perl-json-maybexs \
+       perl-stream-buffered \
+       perl-www-form-urlencoded
+PERL_HTTP_ENTITY_PARSER_LICENSE = Artistic or GPL-1.0+
+PERL_HTTP_ENTITY_PARSER_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))