webkit: fix staging install
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 9 Sep 2013 09:27:55 +0000 (11:27 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 9 Sep 2013 09:27:55 +0000 (11:27 +0200)
Parallel 'make install' seems to deadlock here (make 3.81). Work around it
by disabling parallel make for the install step.

We only disable parallel make for the install step, as the build step works
with parallel make, and webkit is a huge package, so build time goes up
significantly with make -j1.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/webkit/webkit.mk

index 99a90b982a63108580a968dc82fe1bbf2e5a8b08..eb1547bba6e51bd19b8c7f38e96d6b29ff49e0d2 100644 (file)
@@ -15,6 +15,9 @@ WEBKIT_DEPENDENCIES = host-ruby host-flex host-bison host-gperf enchant harfbuzz
 WEBKIT_AUTORECONF = YES
 WEBKIT_AUTORECONF_OPT = -I $(@D)/Source/autotools
 
+# parallel make install deadlocks with make 3.81
+WEBKIT_INSTALL_STAGING_OPT = -j1 DESTDIR=$(STAGING_DIR) install
+
 # Does not build and it's disabled by default
 # in newer releases
 define DISABLE_INDEXED_DATABASE