package/openipmi: add optional support for gdbm
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 09:50:09 +0000 (10:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 11:41:56 +0000 (12:41 +0100)
When gdbm was compiled before, openipmi will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/ipmi_sim | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libgdbm.so.4]
[...]

The build system offers no option to en-/disable gdbm support,
check configure.ac, line 309+

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openipmi/openipmi.mk

index 4dd901b2bca7281da3c47253c2acf673cf71baa4..ea46e191da8e84381d809e6849eb90a94fefc94d 100644 (file)
@@ -23,6 +23,10 @@ OPENIPMI_CONF_OPTS = \
        --with-python=no \
        --with-swig=no
 
+ifeq ($(BR2_PACKAGE_GDBM),y)
+OPENIPMI_DEPENDENCIES += gdbm
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 OPENIPMI_DEPENDENCIES += openssl
 OPENIPMI_CONF_OPTS += --with-openssl=yes