package/smartmontools: add libselinux optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 2 Feb 2020 10:45:11 +0000 (11:45 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Feb 2020 21:01:20 +0000 (22:01 +0100)
libselinux is an optional dependency since a very long time (2010) and
https://github.com/mirror/smartmontools/commit/ab807ee43bd4821f5e0e010de08a746d88506b17

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/smartmontools/smartmontools.mk

index 6c90538f707fd41f04ee3850468c7d6846efa991..bad7da2d160a2a65aa5251e989f95eee69b98428 100644 (file)
@@ -16,4 +16,11 @@ else
 SMARTMONTOOLS_CONF_OPTS += --without-libcap-ng
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSELINUX),y)
+SMARTMONTOOLS_CONF_OPTS += --with-selinux
+SMARTMONTOOLS_DEPENDENCIES += libselinux
+else
+SMARTMONTOOLS_CONF_OPTS += --without-selinux
+endif
+
 $(eval $(autotools-package))