gflags: define NO_THREADS if toolchain doesn't support threads
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>
Thu, 11 Jun 2015 09:40:38 +0000 (15:10 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 11 Jun 2015 20:08:35 +0000 (22:08 +0200)
Fixes:
http://autobuild.buildroot.net/results/a42/a4288ed5050ce0d14e589745bf26c0a95acf645e/

Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gflags/gflags.mk

index 661dad872fec79bba49c137be8f374da8253dc3f..9dc4e15b6fdee7ffd12042295377159939fad545 100644 (file)
@@ -11,7 +11,7 @@ GFLAGS_LICENSE = BSD-3c
 GFLAGS_LICENSE_FILES = COPYING.txt
 
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
-GFLAGS_CONF_OPTS = -DBUILD_gflags_LIB=OFF
+GFLAGS_CONF_OPTS = -DBUILD_gflags_LIB=OFF -DCMAKE_CXX_FLAGS=-DNO_THREADS
 endif
 
 $(eval $(cmake-package))