quagga: fix static linking
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 26 Nov 2015 15:24:59 +0000 (16:24 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 26 Nov 2015 20:16:23 +0000 (21:16 +0100)
This commit adds a patch to quagga's configure.ac to fix a library
ordering problem that is causing a build failure in static linking
scenario.

Fixes:

  http://autobuild.buildroot.org/results/c08/c086f3128232af70d24fd5faf9282ce91d6488ef/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/quagga/0002-configure-fix-static-linking-with-readline.patch [new file with mode: 0644]
package/quagga/quagga.mk

diff --git a/package/quagga/0002-configure-fix-static-linking-with-readline.patch b/package/quagga/0002-configure-fix-static-linking-with-readline.patch
new file mode 100644 (file)
index 0000000..243dfaf
--- /dev/null
@@ -0,0 +1,41 @@
+From 62ede7482da15d276b880f6d8540dce400dc50a7 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Thu, 26 Nov 2015 15:59:07 +0100
+Subject: [PATCH] configure: fix static linking with readline
+
+When static linking is used, the order of the libraries is important,
+and the libraries using a symbol from another library should be listed
+*before* the library providing that symbol (see
+http://eli.thegreenplace.net/2013/07/09/library-order-in-static-linking)
+for details.
+
+When vtysh is linked statically, the command line contains "-lcurses
+-lreadline", which causes a build failure due to unresolved
+symbols. This is because readline is using symbols from the curses
+library: the order should be the opposite.
+
+This patch fixes that problem by putting the -lreadline at the
+beginning of the LIBREADLINE variable calcualted by the configure
+script.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3003e62..290953d 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -652,7 +652,7 @@ dnl         [TODO] on Linux, and in [TODO] on Solaris.
+             )]
+           )]
+         )
+-         AC_CHECK_LIB(readline, main, LIBREADLINE="$LIBREADLINE -lreadline",,
++         AC_CHECK_LIB(readline, main, LIBREADLINE="-lreadline $LIBREADLINE",,
+                       "$LIBREADLINE")
+          if test $ac_cv_lib_readline_main = no; then
+            AC_MSG_ERROR([vtysh needs libreadline but was not found and usable on your system.])
+-- 
+2.6.3
+
index ce1d34b264ca51c7612b87b520e24a779e8e5240..c5dd2ba4e2ee29ebeccee5ab7895e7777fc5e52a 100644 (file)
@@ -11,6 +11,8 @@ QUAGGA_DEPENDENCIES = host-gawk
 QUAGGA_LICENSE = GPLv2+
 QUAGGA_LICENSE_FILES = COPYING
 QUAGGA_CONF_OPTS = --program-transform-name=''
+# 0002-configure-fix-static-linking-with-readline.patch
+QUAGGA_AUTORECONF = YES
 
 QUAGGA_CONF_OPTS += $(if $(BR2_PACKAGE_QUAGGA_ZEBRA),--enable-zebra,--disable-zebra)
 QUAGGA_CONF_OPTS += $(if $(BR2_PACKAGE_QUAGGA_BABELD),--enable-babeld,--disable-babeld)