config: make it possible to specify which config file to use for 'make defconfig'
authorArnout Vandecappelle <arnout@mind.be>
Sat, 28 Apr 2012 07:14:50 +0000 (07:14 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 May 2012 21:38:53 +0000 (23:38 +0200)
So that this works:

 % make defconfig BR2_DEFCONFIG=~/buildroot-defconfig

Right now we have to do:

 % cp ~/buildroot-defconfig configs/buildroot_defconfig
 % make buildroot_defconfig

That would dirty the buildroot tree and requires it to be writable.

Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index cc8124abb78f34251372e74e8c59bccf7a1c0ae1..a7625ba0ee415dc8df1a8ef61c3f91003c4107a5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -540,7 +540,7 @@ silentoldconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
 
 defconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
        @mkdir -p $(BUILD_DIR)/buildroot-config
-       @$(COMMON_CONFIG_ENV) $< --defconfig $(CONFIG_CONFIG_IN)
+       @$(COMMON_CONFIG_ENV) $< --defconfig$(if $(BR2_DEFCONFIG),=$(BR2_DEFCONFIG)) $(CONFIG_CONFIG_IN)
 
 %_defconfig: $(BUILD_DIR)/buildroot-config/conf $(TOPDIR)/configs/%_defconfig outputmakefile
        @mkdir -p $(BUILD_DIR)/buildroot-config
@@ -603,6 +603,7 @@ help:
        @echo '  oldconfig              - resolve any unresolved symbols in .config'
        @echo '  randconfig             - New config with random answer to all options'
        @echo '  defconfig              - New config with default answer to all options'
+       @echo '                             BR2_DEFCONFIG, if set, is used as input'
        @echo '  savedefconfig          - Save current config as ./defconfig (minimal config)'
        @echo '  allyesconfig           - New config where all options are accepted with yes'
        @echo '  allnoconfig            - New config where all options are answered with no'