libxml2: strip libraries in TARGET_DIR
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Jun 2008 21:45:27 +0000 (21:45 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Jun 2008 21:45:27 +0000 (21:45 -0000)
And cleanup libxml2.mk trailing whitespace while we're at it.

package/libxml2/libxml2.mk

index 989761ca2834acd35172470e8a77830f0bb723b3..f04731ca22f290d495b151b53e20d4e54b451c5f 100644 (file)
@@ -21,9 +21,12 @@ LIBXML2_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
                --with-gnu-ld --enable-shared \
                --enable-static --enable-ipv6=no \
                --without-debugging --without-python \
-               --without-threads $(DISABLE_NLS) 
+               --without-threads $(DISABLE_NLS)
 
-
-LIBXML2_DEPENDENCIES = uclibc 
+LIBXML2_DEPENDENCIES = uclibc
 
 $(eval $(call AUTOTARGETS,package,libxml2))
+
+$(LIBXML2_HOOK_POST_INSTALL):
+       $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libxml2*so*
+       touch $@