tcpreplay: cross-compile with tcpdump support
authorChris Packham <judge.packham@gmail.com>
Thu, 23 Jan 2014 09:07:14 +0000 (22:07 +1300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 23 Jan 2014 21:24:57 +0000 (22:24 +0100)
If tcpdump is enabled set ac_cv_path_tcpdump_path so that verbose output
is enabled on the target.

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tcpreplay/tcpreplay.mk

index 0939c6ce5bf0b404cfe77c5bb76fb4835708897f..a2cd16e3966fce7e7cb56cdc26bd744728946bff 100644 (file)
@@ -18,4 +18,10 @@ TCPREPLAY_DEPENDENCIES = libpcap
 TCPREPLAY_LIBS = -lpcap $(if $(BR2_PACKAGE_LIBUSB),-lusb-1.0)
 TCPREPLAY_CONF_ENV += ac_cv_search_pcap_close='$(TCPREPLAY_LIBS)'
 
+ifeq ($(BR2_PACKAGE_TCPDUMP),y)
+TCPREPLAY_CONF_ENV += ac_cv_path_tcpdump_path=/usr/sbin/tcpdump
+else
+TCPREPLAY_CONF_ENV += ac_cv_path_tcpdump_path=no
+endif
+
 $(eval $(autotools-package))