efibootmgr: bump to version 14
authorErico Nunes <nunes.erico@gmail.com>
Fri, 30 Sep 2016 14:46:44 +0000 (16:46 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 2 Oct 2016 11:15:04 +0000 (13:15 +0200)
Upstream has changed version numbering scheme since version 13, which
came after version 0.12.

There is now a make install target, so we can drop the manual file
installing. The make install target also installs the new efibootdump
tool.

Signed-off-by: Erico Nunes <nunes.erico@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/efibootmgr/efibootmgr.hash
package/efibootmgr/efibootmgr.mk

index a789942bb933f06b44fb28bf60b5353246964ad8..f71dced53fb02c00b70c2bf08aa3a957b2f0cab0 100644 (file)
@@ -1,2 +1,2 @@
 # locally computed hash
-sha256 b180d7d6b377d24b0872869f2571e2700b618e4d7ebdc2133134a918efe2623b efibootmgr-efibootmgr-0.12.tar.gz
+sha256 3f260491e2c62e93cb6347ea6f21aaa5f93152e9e7f0269d314623769d82e473 efibootmgr-14.tar.gz
index a0c5646cefb03c10a26f095dd41212d607b9622f..731d6e9f59574c9fee37af816f6e4bdcadb50156 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-EFIBOOTMGR_VERSION = efibootmgr-0.12
+EFIBOOTMGR_VERSION = 14
 EFIBOOTMGR_SITE = $(call github,rhinstaller,efibootmgr,$(EFIBOOTMGR_VERSION))
 EFIBOOTMGR_LICENSE = GPLv2+
 EFIBOOTMGR_LICENSE_FILES = COPYING
@@ -21,8 +21,8 @@ define EFIBOOTMGR_BUILD_CMDS
 endef
 
 define EFIBOOTMGR_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/src/efibootmgr/efibootmgr \
-               $(TARGET_DIR)/usr/bin/efibootmgr
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               DESTDIR=$(TARGET_DIR) install
 endef
 
 $(eval $(generic-package))