libecore: fix build error when X support is disabled but host has X headers
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 Feb 2012 19:52:05 +0000 (20:52 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 Feb 2012 19:52:05 +0000 (20:52 +0100)
Forcibly disable imf-xim as it requires the X support.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libecore/libecore.mk

index 8c462693e283a237892185d210ea249f5bdefd07..2b668ab94fb14be6ae8ac4fe437f232e64d4f13e 100644 (file)
@@ -62,7 +62,7 @@ ifeq ($(BR2_PACKAGE_LIBECORE_X),y)
 LIBECORE_CONF_OPT += --enable-ecore-x
 LIBECORE_DEPENDENCIES += xlib_libXext xlib_libX11
 else
-LIBECORE_CONF_OPT += --disable-ecore-x
+LIBECORE_CONF_OPT += --disable-ecore-x --disable-ecore-imf-xim
 endif
 
 ifeq ($(BR2_PACKAGE_LIBECORE_X_XCB),y)