xenomai: use install-user to remove patch
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Oct 2013 22:41:45 +0000 (23:41 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Nov 2013 14:40:06 +0000 (15:40 +0100)
As noted by "George" in bug #6416, the xenomai-do-not-install-devices
patch is not needed, since Xenomai provides a "install-user" target to
only install the libraries/headers and not the device files. This
patch changes xenomai.mk to use 'install-user' and removes the useless
patch.

Fixes bug #6416.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xenomai/xenomai-do-not-install-devices.patch [deleted file]
package/xenomai/xenomai.mk

diff --git a/package/xenomai/xenomai-do-not-install-devices.patch b/package/xenomai/xenomai-do-not-install-devices.patch
deleted file mode 100644 (file)
index 348abee..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile.in      2011-06-24 16:11:23.591449817 +0200
-+++ b/Makefile.in      2011-06-24 16:20:29.638129633 +0200
-@@ -719,7 +719,7 @@
-         $$sudo mknod -m 666 $(DESTDIR)/dev/rtheap c 10 254 ; \
-       fi
--install-exec-local: devices
-+install-exec-local:
- install-user:
-       $(MAKE) SUDO=false install
index f10dec0c9307714c81865373e591ece28774062d..786bdfd21123345507671c14e8aad599a4939998 100644 (file)
@@ -16,6 +16,8 @@ XENOMAI_LICENSE = headers: GPLv2+ with exception, libraries: LGPLv2.1+, kernel:
 XENOMAI_LICENSE_FILES = debian/copyright include/COPYING src/skins/native/COPYING ksrc/nucleus/COPYING
 
 XENOMAI_INSTALL_STAGING = YES
+XENOMAI_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-user
+XENOMAI_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install-user
 
 XENOMAI_CONF_OPT += --includedir=/usr/include/xenomai/