package/alsa-utils: Fix alsa-plugins compatibility
authorGleb Mazovetskiy <glex.spb@gmail.com>
Wed, 25 Aug 2021 15:16:59 +0000 (16:16 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 25 Aug 2021 20:12:26 +0000 (22:12 +0200)
Previously, alsa-plugins would not work if alsa-utils was installed
after it. This happened because:

1. alsa-plugins copies some files $(TARGET_DIR)/usr/share/alsa/alsa.conf.d
2. alsa-utils removes these files during installation ( rm -rf $(TARGET_DIR)/usr/share/alsa/;)

The `rm -rf` command was originally added as part of the fix for
https://bugs.buildroot.org/show_bug.cgi?id=1573 11 years ago.

The intention might have been to allow for unconfiguring some options
and then rebuilding alsa-utils. However, this is a scenario that does
not work anyway.

The simplest fix for the `alsa-plugins` compatibility issue appears to
be to remove the `rm -rf` command.

Signed-off-by: Gleb Mazovetskiy <glex.spb@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/alsa-utils/alsa-utils.mk

index 2658c827a0013ce4cc15a5b52dcdbf9a97651b0c..427280c1e6cf8eaa7efff758a32136ce728e9166 100644 (file)
@@ -77,7 +77,6 @@ define ALSA_UTILS_INSTALL_TARGET_CMDS
        fi
        if [ -x "$(TARGET_DIR)/usr/sbin/alsactl" ]; then \
                mkdir -p $(TARGET_DIR)/usr/share/; \
-               rm -rf $(TARGET_DIR)/usr/share/alsa/; \
                cp -rdpf $(STAGING_DIR)/usr/share/alsa/ $(TARGET_DIR)/usr/share/alsa/; \
        fi
 endef